summaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Kuruvila <arun.kuruvila@oracle.com>2015-06-30 10:27:12 +0530
committerArun Kuruvila <arun.kuruvila@oracle.com>2015-06-30 10:27:12 +0530
commit7c5d18e2271ce4fcd9294511860841dbb4fec31a (patch)
tree94914c21097ad1759f8a40396a8d0db6cae45c33 /client/CMakeLists.txt
parent9068238b1984100dc2251f742a994b18fafaa841 (diff)
downloadmariadb-git-7c5d18e2271ce4fcd9294511860841dbb4fec31a.tar.gz
Bug #20772273 : MYSQLIMPORT --USE-THREADS DOESN'T USE
MULTIPLE THREADS Description:- The utility "mysqlimport" does not use multiple threads for the execution with option "--use-threads". "mysqlimport" while importing multiple files and multiple tables, uses a single thread even if the number of threads are specified with "--use-threads" option. Analysis:- This utility uses ifdef HAVE_LIBPTHREAD to check for libpthread library and if defined uses libpthread library for mutlithreaing. Since HAVE_LIBPTHREAD is not defined anywhere in the source, "--use-threads" option is silently ignored. Fix:- "-DTHREADS" is set to the COMPILE_FLAGS which will enable pthreads. HAVE_LIBPTHREAD macro is removed.
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 0d67cf2e0d4..21b1e084409 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2006, 2011, Oracle and/or its affiliates. All rights reserved.
+# Copyright (c) 2006, 2015, Oracle and/or its affiliates. All rights reserved.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -51,6 +51,7 @@ MYSQL_ADD_EXECUTABLE(mysqldump mysqldump.c ../sql-common/my_user.c)
TARGET_LINK_LIBRARIES(mysqldump mysqlclient)
MYSQL_ADD_EXECUTABLE(mysqlimport mysqlimport.c)
+SET_SOURCE_FILES_PROPERTIES(mysqlimport.c PROPERTIES COMPILE_FLAGS "-DTHREADS")
TARGET_LINK_LIBRARIES(mysqlimport mysqlclient)
MYSQL_ADD_EXECUTABLE(mysql_upgrade mysql_upgrade.c)