summaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bruehe <joerg@mysql.com>2010-09-06 13:26:23 +0200
committerJoerg Bruehe <joerg@mysql.com>2010-09-06 13:26:23 +0200
commit8fd74f66a9e20c1f36ae28306c279eab2ce01aeb (patch)
tree8e33ff224613bbee9db91cdf4261e0c519b8b966 /client/CMakeLists.txt
parentaad96fccada6d9077505117731a379cd2be8109a (diff)
downloadmariadb-git-8fd74f66a9e20c1f36ae28306c279eab2ce01aeb.tar.gz
Fix bug#56547 mysql client interprets commands in comments
The problem was not caused by a change in the client, rather by the tests using the Windows built-in "echo" and not the one built by MySQL. This again happened because the binary was missing in the package, caused by the wrong macro being used to build it in "cmake".
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 771ebf290f1..e39e8d7178a 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -64,7 +64,10 @@ MYSQL_ADD_EXECUTABLE(mysqlslap mysqlslap.c)
SET_SOURCE_FILES_PROPERTIES(mysqlslap.c PROPERTIES COMPILE_FLAGS "-DTHREADS")
TARGET_LINK_LIBRARIES(mysqlslap mysqlclient)
-ADD_EXECUTABLE(echo echo.c)
+# "WIN32" also covers 64 bit. "echo" is used in some files below "mysql-test/".
+IF(WIN32)
+ MYSQL_ADD_EXECUTABLE(echo echo.c)
+ENDIF(WIN32)
SET_TARGET_PROPERTIES (mysqlcheck mysqldump mysqlimport mysql_upgrade mysqlshow mysqlslap
PROPERTIES HAS_CXX TRUE)