summaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <df@pippilotta.erinye.com>2007-06-04 14:29:54 +0200
committerunknown <df@pippilotta.erinye.com>2007-06-04 14:29:54 +0200
commit9c76ac256716bd148b8f4f9212f6e8eb083e8507 (patch)
treea10115ff0526b7eac8735fb813ec4446c8674a87 /client/CMakeLists.txt
parentcaa9e04dc271a28e5bdbfe9d8b741701509d46cc (diff)
downloadmariadb-git-9c76ac256716bd148b8f4f9212f6e8eb083e8507.tar.gz
BUG#28860 port to 5.1
client/CMakeLists.txt: Use USE_TLS for mysqlclient.lib
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 8ec8b0111b0..69d39886e9a 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -20,6 +20,10 @@ SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
# The old Windows build method used renamed (.cc -> .cpp) source files, fails
# in #include in mysqlbinlog.cc. So disable that using the USING_CMAKE define.
ADD_DEFINITIONS(-DUSING_CMAKE)
+
+# USE_TLS needed because of bug#28860
+ADD_DEFINITIONS(-DUSE_TLS)
+
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include
${CMAKE_SOURCE_DIR}/zlib
${CMAKE_SOURCE_DIR}/extra/yassl/include