summaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <iggy@recycle.(none)>2007-04-23 15:41:24 -0400
committerunknown <iggy@recycle.(none)>2007-04-23 15:41:24 -0400
commit1ce0d7c63b33bd7970b6ab53884e726858cee92d (patch)
tree20f198c8c6f8c6d19d7e0fae61409ab144e819dd /client/CMakeLists.txt
parentb44eee2a6739afb44f59a06c2f7adb309f66b6a9 (diff)
downloadmariadb-git-1ce0d7c63b33bd7970b6ab53884e726858cee92d.tar.gz
Bug#24732 Executables do not include Vista manifests
- Added script to generate application specific manifest. - Added new CMake MACRO to add customer build events which will first generate a manifest and then embeds that manifest into an executable. BitKeeper/etc/ignore: Bug#24732 Executables do not include Vista manifests - Revise ignore rules to disallow auto-generated cmake files but to allow custom macros defined in a .cmake file. CMakeLists.txt: Bug#24732 Executables do not include Vista manifests - Added logic for EMBED_MANIFESTS configuration option. client/CMakeLists.txt: Bug#24732 Executables do not include Vista manifests - Embed manifest with custom CMake MACRO for client executables. extra/CMakeLists.txt: Bug#24732 Executables do not include Vista manifests - Embed manifest with custom CMake MACRO for my_print_default executable. libmysql/CMakeLists.txt: Bug#24732 Executables do not include Vista manifests - Embed manifest with custom CMake MACRO for myTest executable. myisam/CMakeLists.txt: Bug#24732 Executables do not include Vista manifests - Embed manifest with custom CMake MACRO for myisam executables. server-tools/instance-manager/CMakeLists.txt: Bug#24732 Executables do not include Vista manifests - Embed manifest with custom CMake MACRO for mysqlmanager executable. sql/CMakeLists.txt: Bug#24732 Executables do not include Vista manifests - Embed manifest with custom CMake MACRO for mysqld executable. win/README: Bug#24732 Executables do not include Vista manifests - Added new configuration option documentation. win/configure.js: Bug#24732 Executables do not include Vista manifests - Added new EMBED_MANIFESTS configuration option. win/create_manifest.js: Bug#24732 Executables do not include Vista manifests - Manifest generator. This script generates a basic manifest. win/mysql_manifest.cmake: Bug#24732 Executables do not include Vista manifests - Define new CMake MACRO for adding Windows manifests to executables.
Diffstat (limited to 'client/CMakeLists.txt')
-rwxr-xr-xclient/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index b598c77ddfc..6e37d02ecd8 100755
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -12,6 +12,7 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+INCLUDE("${PROJECT_SOURCE_DIR}/win/mysql_manifest.cmake")
SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
@@ -98,3 +99,16 @@ TARGET_LINK_LIBRARIES(mysqladmin mysqlclient mysys dbug yassl taocrypt zlib wsoc
ADD_EXECUTABLE(echo echo.c)
+IF(EMBED_MANIFESTS)
+ MYSQL_EMBED_MANIFEST("mysql" "asInvoker")
+ MYSQL_EMBED_MANIFEST("mysqltest" "asInvoker")
+ MYSQL_EMBED_MANIFEST("mysqlcheck" "asInvoker")
+ MYSQL_EMBED_MANIFEST("mysqldump" "asInvoker")
+ MYSQL_EMBED_MANIFEST("mysqlimport" "asInvoker")
+ MYSQL_EMBED_MANIFEST("mysql_upgrade" "asInvoker")
+ MYSQL_EMBED_MANIFEST("mysqlshow" "asInvoker")
+ MYSQL_EMBED_MANIFEST("mysqlbinlog" "asInvoker")
+ MYSQL_EMBED_MANIFEST("mysqladmin" "asInvoker")
+ MYSQL_EMBED_MANIFEST("echo" "asInvoker")
+ENDIF(EMBED_MANIFESTS)
+