summaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorAntony@floppy. <>2007-03-22 00:43:14 -0700
committerAntony@floppy. <>2007-03-22 00:43:14 -0700
commitadfdcb191ca1a0d48db3c760ea186e0502664310 (patch)
treea483abdfae7bb71c7e9521103ae6fc24ee39cbe5 /client/CMakeLists.txt
parent132608419ef5b495d59e6418f2305ceb24a1e9c6 (diff)
downloadmariadb-git-adfdcb191ca1a0d48db3c760ea186e0502664310.tar.gz
Fixes for 5.1-arch repository to compile on Windows.
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index d492c49a6b2..ea9e7547354 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -95,6 +95,7 @@ ADD_EXECUTABLE(mysqladmin mysqladmin.cc)
TARGET_LINK_LIBRARIES(mysqladmin mysqlclient mysys dbug yassl taocrypt zlib wsock32)
ADD_EXECUTABLE(mysqlslap mysqlslap.c)
+SET_SOURCE_FILES_PROPERTIES(mysqlslap.c PROPERTIES COMPILE_FLAGS "-DTHREADS")
TARGET_LINK_LIBRARIES(mysqlslap mysqlclient mysys yassl taocrypt zlib wsock32 dbug)
ADD_EXECUTABLE(echo echo.c)