summaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authormsvensson@neptunus.(none) <>2006-11-27 15:00:08 +0100
committermsvensson@neptunus.(none) <>2006-11-27 15:00:08 +0100
commit545fac620fceccd5f7e9a100e96925aa4441f1ca (patch)
treef2ee82eb439829e3d7db268ffc1ca903975d9c95 /client/CMakeLists.txt
parenta45b64b1342f7b002439c85b0864be512172b30a (diff)
downloadmariadb-git-545fac620fceccd5f7e9a100e96925aa4441f1ca.tar.gz
Add mysys/my_getpagesize as source file foir mysql_upgrade
Don't link mysql_upgrade with mysys
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index b2b734a48f4..c3dd57f098b 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -65,8 +65,8 @@ TARGET_LINK_LIBRARIES(mysqldump mysqlclient mysys dbug yassl taocrypt zlib wsock
ADD_EXECUTABLE(mysqlimport mysqlimport.c)
TARGET_LINK_LIBRARIES(mysqlimport mysqlclient mysys dbug yassl taocrypt zlib wsock32)
-ADD_EXECUTABLE(mysql_upgrade mysql_upgrade.c)
-TARGET_LINK_LIBRARIES(mysql_upgrade mysqlclient mysys dbug yassl taocrypt zlib wsock32)
+ADD_EXECUTABLE(mysql_upgrade mysql_upgrade.c ../mysys/my_getpagesize.c)
+TARGET_LINK_LIBRARIES(mysql_upgrade mysqlclient dbug yassl taocrypt zlib wsock32)
ADD_EXECUTABLE(mysqlshow mysqlshow.c)
TARGET_LINK_LIBRARIES(mysqlshow mysqlclient mysys dbug yassl taocrypt zlib wsock32)