summaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authordf@pippilotta.erinye.com <>2007-06-04 14:12:31 +0200
committerdf@pippilotta.erinye.com <>2007-06-04 14:12:31 +0200
commit32f4cfb8a957e0152abf0785347756068f2cbf5d (patch)
treeaa83e7a583180530ab7eadee31fc4cd719cefea4 /client/CMakeLists.txt
parent11c834516621cbacf292d437cd708b829ebd8dfb (diff)
downloadmariadb-git-32f4cfb8a957e0152abf0785347756068f2cbf5d.tar.gz
BUG#28860 USE_TLS not defined for mysqlclient.lib
Diffstat (limited to 'client/CMakeLists.txt')
-rwxr-xr-xclient/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 6e37d02ecd8..a829876fec3 100755
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -20,6 +20,10 @@ SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
# The old Windows build method used renamed (.cc -> .cpp) source files, fails
# in #include in mysqlbinlog.cc. So disable that using the USING_CMAKE define.
ADD_DEFINITIONS(-DUSING_CMAKE)
+
+# USE_TLS needed because of bug#28860
+ADD_DEFINITIONS(-DUSE_TLS)
+
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include
${CMAKE_SOURCE_DIR}/zlib
${CMAKE_SOURCE_DIR}/extra/yassl/include