summaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authordf@pippilotta.erinye.com <>2007-06-04 14:29:54 +0200
committerdf@pippilotta.erinye.com <>2007-06-04 14:29:54 +0200
commit1161d74a3ad69e51211a8d0346fbf717e769311a (patch)
treea10115ff0526b7eac8735fb813ec4446c8674a87 /client/CMakeLists.txt
parenta167ec0fbe58ab22384c3abcbc677177a8ec30f2 (diff)
downloadmariadb-git-1161d74a3ad69e51211a8d0346fbf717e769311a.tar.gz
BUG#28860 port to 5.1
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 8ec8b0111b0..69d39886e9a 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -20,6 +20,10 @@ SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
# The old Windows build method used renamed (.cc -> .cpp) source files, fails
# in #include in mysqlbinlog.cc. So disable that using the USING_CMAKE define.
ADD_DEFINITIONS(-DUSING_CMAKE)
+
+# USE_TLS needed because of bug#28860
+ADD_DEFINITIONS(-DUSE_TLS)
+
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include
${CMAKE_SOURCE_DIR}/zlib
${CMAKE_SOURCE_DIR}/extra/yassl/include