summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorunknown <acurtis/antony@xiphis.org/ltamd64.xiphis.org>2007-03-22 01:59:47 -0700
committerunknown <acurtis/antony@xiphis.org/ltamd64.xiphis.org>2007-03-22 01:59:47 -0700
commitc8e15cf23bb031096682ff4ebc413a2ff6a3abf3 (patch)
treee16eac6aad949684d92c9eb397582bc1c8c75b95 /client/Makefile.am
parent2b9fdea8c6eff96b938dfd0a47331a02ca186760 (diff)
downloadmariadb-git-c8e15cf23bb031096682ff4ebc413a2ff6a3abf3.tar.gz
fixes for 5.1-arch repository
client/Makefile.am: fix flags to ensure that mysqlslap still compiles on Unix
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 1c908ea715e..4b78ee2b0c9 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -76,6 +76,7 @@ mysqlimport_LDADD = $(CXXLDFLAGS) $(CLIENT_THREAD_LIBS) \
mysqlshow_SOURCES= mysqlshow.c
mysqlslap_SOURCES= mysqlslap.c
+mysqlslap_CFLAGS= -DTHREAD -UUNDEF_THREADS_HACK
mysqlslap_LDADD = $(CXXLDFLAGS) $(CLIENT_THREAD_LIBS) \
@CLIENT_EXTRA_LDFLAGS@ \
$(LIBMYSQLCLIENT_LA) \