summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2006-02-18 04:23:24 +0100
committerunknown <kent@mysql.com>2006-02-18 04:23:24 +0100
commit3470647a6d832ccf06ded76780bb9eadfccfde5b (patch)
treed7a5ccbcb1e9dedfdbc4c5c6c88334edfb9050f4 /client/Makefile.am
parent8c62b871439e78c8f33d464fb0fe6ae89e127057 (diff)
downloadmariadb-git-3470647a6d832ccf06ded76780bb9eadfccfde5b.tar.gz
Makefile.am:
Add an extra -lpthread before first -lc, to solve link problems when statically linking with glibc 2.2.5 make_win_src_distribution.sh: Added copying of the include/mysql directory scripts/make_win_src_distribution.sh: Added copying of the include/mysql directory client/Makefile.am: Add redundant CLIENT_THREAD_LIBS to LDADD, to make -lpthread go before -lc, required for the static linking with glibc 2.2.5 to work.
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 14ebadbfacb..e77d47a2670 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -27,7 +27,7 @@ INCLUDES = -I$(top_builddir)/include \
-I$(top_srcdir)/regex \
$(openssl_includes) $(yassl_includes)
LIBS = @CLIENT_LIBS@
-LDADD= @CLIENT_EXTRA_LDFLAGS@ \
+LDADD= @CLIENT_EXTRA_LDFLAGS@ $(CLIENT_THREAD_LIBS) \
$(top_builddir)/libmysql/libmysqlclient.la
bin_PROGRAMS = mysql mysqladmin mysqlcheck mysqlshow \
mysqldump mysqlimport mysqltest mysqlbinlog \
@@ -57,7 +57,7 @@ mysqlcheck_SOURCES= mysqlcheck.c $(yassl_dummy_link_fix)
mysqlshow_SOURCES= mysqlshow.c $(yassl_dummy_link_fix)
mysqlslap_SOURCES= mysqlslap.c $(top_srcdir)/mysys/my_lock.c \
$(top_srcdir)/mysys/my_alarm.c \
- $(yassl_dummy_link_fix)
+ $(yassl_dummy_link_fix)
mysqldump_SOURCES= mysqldump.c my_user.c $(yassl_dummy_link_fix)
mysqlimport_SOURCES= mysqlimport.c \
$(yassl_dummy_link_fix)
@@ -71,14 +71,14 @@ link_sources:
for f in $(sql_src) ; do \
rm -f $$f; \
@LN_CP_F@ $(top_srcdir)/sql/$$f $$f; \
- done; \
+ done; \
for f in $(strings_src) ; do \
rm -f $(srcdir)/$$f; \
@LN_CP_F@ $(top_srcdir)/strings/$$f $$f; \
- done; \
- rm -f $(srcdir)/my_user.c; \
- @LN_CP_F@ $(top_srcdir)/sql-common/my_user.c my_user.c;
-
+ done; \
+ rm -f $(srcdir)/my_user.c; \
+ @LN_CP_F@ $(top_srcdir)/sql-common/my_user.c my_user.c
+
# Don't update the files from bitkeeper
%::SCCS/s.%