summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorunknown <petr@mysql.com>2005-04-04 03:49:10 +0400
committerunknown <petr@mysql.com>2005-04-04 03:49:10 +0400
commitd67f4397dc62bc7270f0e4bdaa2095f9a0959548 (patch)
tree7ee4a6ad37f2a883eaae5ba52e4bade76c87adf6 /client/Makefile.am
parentba8dc8e9f216e06533973bc2810751f0be42221d (diff)
downloadmariadb-git-d67f4397dc62bc7270f0e4bdaa2095f9a0959548.tar.gz
Enable IM in the binary distribution and fix Bug #9513 (mysql.server script from the binary distibution
doesn't work out of the box) client/Makefile.am: old mysqlmanager, mysqlmanagerc and mysqlmanager-pwgen renamed into mysqltestmanager, mysqltestmanagerc and mysqltestmanager-pwgen respectively mysql-test/mysql-test-run.sh: Old mysqlmanager, mysqlmanagerc and mysqlmanager-pwgen renamed into mysqltestmanager, mysqltestmanagerc and mysqltestmanager-pwgen respectively scripts/make_binary_distribution.sh: Fix the script to include IM and process mysql.server correctly server-tools/instance-manager/Makefile.am: change default socket name to follow mysqld style (and thus, fix the ptoblem with non-existant localstatedir in the binary distribution) support-files/mysql.spec.sh: Fix mysql.spec template to reflect the name change tools/Makefile.am: old mysqlmanager renamed into mysqltestmanager
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index d3307f9da42..58dcebfd852 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -23,7 +23,8 @@ LIBS = @CLIENT_LIBS@
LDADD= @CLIENT_EXTRA_LDFLAGS@ \
$(top_builddir)/libmysql/libmysqlclient.la
bin_PROGRAMS = mysql mysqladmin mysqlcheck mysqlshow \
- mysqldump mysqlimport mysqltest mysqlbinlog mysqlmanagerc mysqlmanager-pwgen
+ mysqldump mysqlimport mysqltest mysqlbinlog \
+ mysqltestmanagerc mysqltestmanager-pwgen
noinst_HEADERS = sql_string.h completion_hash.h my_readline.h \
client_priv.h
mysql_SOURCES = mysql.cc readline.cc sql_string.cc completion_hash.cc
@@ -33,7 +34,8 @@ mysqlbinlog_LDADD = $(LDADD) $(CXXLDFLAGS)
mysqltest_SOURCES= mysqltest.c $(top_srcdir)/mysys/my_getsystime.c
mysqltest_LDADD = $(top_builddir)/regex/libregex.a $(LDADD)
mysqlbinlog_SOURCES = mysqlbinlog.cc $(top_srcdir)/mysys/mf_tempdir.c
-mysqlmanagerc_SOURCES = mysqlmanagerc.c
+mysqltestmanagerc_SOURCES = mysqlmanagerc.c
+mysqltestmanager_pwgen_SOURCES = mysqlmanager-pwgen.c
sql_src=log_event.h mysql_priv.h log_event.cc my_decimal.h my_decimal.cc
strings_src=decimal.c