summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorunknown <svoj@mysql.com>2005-06-12 18:18:46 +0500
committerunknown <svoj@mysql.com>2005-06-12 18:18:46 +0500
commit3d43153655c9c352ce9fc783a0afe8402994f321 (patch)
treeb85af950dec5e1657f0299eb81122f1953146d41 /client/Makefile.am
parentb85705cce12b178efdfd813de06326882cd24b40 (diff)
downloadmariadb-git-3d43153655c9c352ce9fc783a0afe8402994f321.tar.gz
WL#2286 - Compile MySQL w/YASSL support
Fix for link failures on boxes with non-gnu compiler. client/Makefile.am: Add a dummy C++ file to client suite to make libtool use a C++ linker: this lets client suite link when using yaSSL and a non-gcc C++ compiler. config/ac-macros/yassl.m4: HAVE_YASSL conditional is used to add dummy C++ file if configured with yaSSL. tests/Makefile.am: Add a dummy C++ file to tests to make libtool use a C++ linker: this lets tests link when using yaSSL and a non-gcc C++ compiler. vio/Makefile.am: Use dummy C++ file if configured with yaSSL only.
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 791da2760a5..a301d55efe4 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -16,6 +16,11 @@
# This file is public domain and comes with NO WARRANTY of any kind
+if HAVE_YASSL
+ yassl_dummy_link_fix= $(top_srcdir)/extra/yassl/src/dummy.cpp
+else
+ yassl_dummy_link_fix=
+endif
#AUTOMAKE_OPTIONS = nostdinc
INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/regex \
$(openssl_includes) -I$(top_builddir)/include
@@ -30,12 +35,17 @@ noinst_HEADERS = sql_string.h completion_hash.h my_readline.h \
mysql_SOURCES = mysql.cc readline.cc sql_string.cc completion_hash.cc
mysqladmin_SOURCES = mysqladmin.cc
mysql_LDADD = @readline_link@ @TERMCAP_LIB@ $(LDADD) $(CXXLDFLAGS)
-mysqltest_SOURCES= mysqltest.c $(top_srcdir)/mysys/my_getsystime.c
+mysqltest_SOURCES= mysqltest.c $(top_srcdir)/mysys/my_getsystime.c \
+ $(yassl_dummy_link_fix)
mysqltest_LDADD = $(top_builddir)/regex/libregex.a $(LDADD)
mysqlbinlog_SOURCES = mysqlbinlog.cc $(top_srcdir)/mysys/mf_tempdir.c $(top_srcdir)/mysys/my_new.cc
mysqlbinlog_LDADD = $(LDADD) $(CXXLDFLAGS)
-mysqltestmanagerc_SOURCES = mysqlmanagerc.c
mysqltestmanager_pwgen_SOURCES = mysqlmanager-pwgen.c
+mysqltestmanagerc_SOURCES= mysqlmanagerc.c $(yassl_dummy_link_fix)
+mysqlcheck_SOURCES= mysqlcheck.c $(yassl_dummy_link_fix)
+mysqlshow_SOURCES= mysqlshow.c $(yassl_dummy_link_fix)
+mysqldump_SOURCES= mysqldump.c $(yassl_dummy_link_fix)
+mysqlimport_SOURCES= mysqlimport.c $(yassl_dummy_link_fix)
sql_src=log_event.h mysql_priv.h log_event.cc my_decimal.h my_decimal.cc
strings_src=decimal.c