summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorunknown <sasha@mysql.sashanet.com>2001-08-09 18:16:43 -0600
committerunknown <sasha@mysql.sashanet.com>2001-08-09 18:16:43 -0600
commit8ddf0c441464bcb19595ff7735d3f0de8a54318f (patch)
tree9d06bd339f6bb64b768d1643ebf486cac78790a1 /client/Makefile.am
parentc67510f0939fbcad4f2f0efcc79272322d5ffa57 (diff)
downloadmariadb-git-8ddf0c441464bcb19595ff7735d3f0de8a54318f.tar.gz
mysqlbinlog->client
BitKeeper/etc/ignore: Added client/log_event.cc client/log_event.h client/mf_iocache.c client/mf_iocache.cc client/mysqlbinlog client/mysys_priv.h mysql.kdevprj to the ignore list Makefile.am: do symlink hack in the client directory ( originally needed to get log_event.cc for mysqlbinlog) client/mysqlbinlog.cc: fixes to make it compile in the client directory libmysql/Makefile.shared: link mysqlbinlog dependencies into libmysqlclient libmysql/libmysql.c: make simple_command and net_safe_read extern ( for mysqlbinlog) sql/log_event.cc: removed pthread dependency in mysqlbinlog sql/log_event.h: removed pthread dependency in mysqlbinlog
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 24221dcab74..c05f6a396dc 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -21,7 +21,8 @@ INCLUDES = -I$(srcdir)/../include \
-I..
LIBS = @CLIENT_LIBS@
LDADD = @CLIENT_EXTRA_LDFLAGS@ ../libmysql/libmysqlclient.la
-bin_PROGRAMS = mysql mysqladmin mysqlcheck mysqlshow mysqldump mysqlimport mysqltest
+bin_PROGRAMS = mysql mysqladmin mysqlcheck mysqlshow \
+ mysqldump mysqlimport mysqltest mysqlbinlog
noinst_PROGRAMS = insert_test select_test thread_test
noinst_HEADERS = sql_string.h completion_hash.h my_readline.h
mysql_SOURCES = mysql.cc readline.cc sql_string.cc completion_hash.cc
@@ -36,10 +37,24 @@ insert_test_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)
select_test_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)
mysqltest_SOURCES= mysqltest.c
mysqltest_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)
+mysqlbinlog_SOURCES = mysqlbinlog.cc
+mysqlbinlog_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES)
+sql_src=log_event.h log_event.cc
+mysys_src=mysys_priv.h
# Fix for mit-threads
DEFS = -DUNDEF_THREADS_HACK
+link_sources:
+ for f in $(sql_src) ; do \
+ rm -f $$f; \
+ @LN_CP_F@ ../sql/$$f $$f; \
+ done; \
+ for f in $(mysys_src); do \
+ rm -f $$f; \
+ @LN_CP_F@ ../mysys/$$f $$f; \
+ done;
+
thread_test.o: thread_test.c
$(COMPILE) -c @MT_INCLUDES@ $(INCLUDES) $<