summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorunknown <brian@zim.(none)>2005-12-28 18:41:06 -0800
committerunknown <brian@zim.(none)>2005-12-28 18:41:06 -0800
commit6a8cc394cfbee3b932fd0a53725012d2103c2655 (patch)
treef800c48cf9de5e2352f31a8b9d176ed2736ae0df /client/Makefile.am
parent66f962d808111c63e4aa03371b5520beb72c3a73 (diff)
downloadmariadb-git-6a8cc394cfbee3b932fd0a53725012d2103c2655.tar.gz
Added option --lock-directory so that you can now syncronize several mysqlslap processes across several machines. Not perfect yet.
Added --slave option if you are trying to syncronize around one server using the lock-directory option plus NFS. Added options to allow you to run several concurrency runs in one call. aka --concurrency="1, 8, 64, 128" Time collection is now done in a finer grain manner, and is linked to the sync call (doesn't count the cost of the blocked processes that are setup to run). client/Makefile.am: Adding my_lock compile bits so we can have locking. client/client_priv.h: New options for lock directory, number of query, number of rows and slave status. client/mysqlslap.c: Updates for lock-directory. Simplified fork() code that is called. It should be possible to build now a version that used threads if someone wanted to port to windows). You can now specify several concurrency runs in one pass of the code.
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index fe3620bbad7..8b6da68a659 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -52,7 +52,9 @@ mysqltestmanager_pwgen_SOURCES = mysqlmanager-pwgen.c
mysqltestmanagerc_SOURCES= mysqlmanagerc.c $(yassl_dummy_link_fix)
mysqlcheck_SOURCES= mysqlcheck.c $(yassl_dummy_link_fix)
mysqlshow_SOURCES= mysqlshow.c $(yassl_dummy_link_fix)
-mysqlslap_SOURCES= mysqlslap.c $(yassl_dummy_link_fix)
+mysqlslap_SOURCES= mysqlslap.c $(top_srcdir)/mysys/my_lock.c \
+ $(top_srcdir)/mysys/my_alarm.c \
+ $(yassl_dummy_link_fix)
mysqldump_SOURCES= mysqldump.c $(yassl_dummy_link_fix)
mysqlimport_SOURCES= mysqlimport.c $(yassl_dummy_link_fix)
sql_src=log_event.h mysql_priv.h log_event.cc my_decimal.h my_decimal.cc