summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2004-12-10 13:06:58 +0100
committerunknown <kent@mysql.com>2004-12-10 13:06:58 +0100
commitd408a4aad1c224bfd8be64dbdd705fd17678bef9 (patch)
treeb71d3846d8d8cbf93a106fd06ae45675602b59fa /client/Makefile.am
parent7a60d1558a89df5f198884d360a14bf2b48f2c49 (diff)
downloadmariadb-git-d408a4aad1c224bfd8be64dbdd705fd17678bef9.tar.gz
Makefile.am:
Moved "../regex/libregex.a" before "../libmysql/libmysqlclient.la" when linking. For -all-static linking libtool put -lc after the .la file and this put the libc regex functions before our regex functions when linking on Linux. client/Makefile.am: Moved "../regex/libregex.a" before "../libmysql/libmysqlclient.la" when linking, for static linking libtool put -lc after the .la and this put the libc regex functions before out regex functions in the link on Linux.
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index fa317367f71..0404aacb383 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -21,6 +21,7 @@ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/regex \
$(openssl_includes)
LIBS = @CLIENT_LIBS@
DEPLIB= ../libmysql/libmysqlclient.la
+REGEXLIB= ../regex/libregex.a
LDADD = @CLIENT_EXTRA_LDFLAGS@ $(DEPLIB)
bin_PROGRAMS = mysql mysqladmin mysqlcheck mysqlshow \
mysqldump mysqlimport mysqltest mysqlbinlog mysqlmanagerc mysqlmanager-pwgen
@@ -37,8 +38,8 @@ mysqlshow_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES) $(DEPLIB)
mysqldump_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES) $(DEPLIB)
mysqlimport_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES) $(DEPLIB)
mysqltest_SOURCES= mysqltest.c ../mysys/my_getsystime.c
-mysqltest_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES) $(DEPLIB)
-mysqltest_LDADD = $(LDADD) $(top_builddir)/regex/libregex.a
+mysqltest_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES) $(REGEXLIB) $(DEPLIB)
+mysqltest_LDADD = $(REGEXLIB) $(LDADD)
mysqlbinlog_SOURCES = mysqlbinlog.cc ../mysys/mf_tempdir.c
mysqlbinlog_DEPENDENCIES= $(LIBRARIES) $(pkglib_LTLIBRARIES) $(DEPLIB)
mysqlmanagerc_SOURCES = mysqlmanagerc.c