summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorunknown <brian@zim.tangent.org>2006-02-13 00:45:59 -0800
committerunknown <brian@zim.tangent.org>2006-02-13 00:45:59 -0800
commitbee0941d401168fd1688036900b9b8d1a613db0b (patch)
treea1e383dff70acb11f347b245f59fabed944ac3ce /client/Makefile.am
parent033b29eee0cad528c890cfa53246f6d7f04b5189 (diff)
downloadmariadb-git-bee0941d401168fd1688036900b9b8d1a613db0b.tar.gz
Adding thread support for mysqlimport. You can now specify a number of threads to use and it will thread the loading of the database. Anyone who has had to go through the pain of loading the database will immediatly get the reason for this.
client/Makefile.am: Adding client_thread_libs for mysqlimport (aka it gets pthreads) client/client_priv.h: New option client/mysqlimport.c: Reworked logic to allow someone to use threads. mysql-test/r/mysqldump.result: New results mysql-test/t/mysqldump.test: Added tests for threads.
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 849bd37eb57..6a851cf2f2c 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -49,6 +49,7 @@ mysqlbinlog_SOURCES = mysqlbinlog.cc $(top_srcdir)/mysys/mf_tempdir.c \
$(top_srcdir)/mysys/base64.c
mysqlbinlog_LDADD = $(LDADD) $(CXXLDFLAGS)
mysqlslap_LDADD = $(LDADD) $(CXXLDFLAGS) $(CLIENT_THREAD_LIBS)
+mysqlimport_LDADD = $(LDADD) $(CXXLDFLAGS) $(CLIENT_THREAD_LIBS)
mysqltestmanager_pwgen_SOURCES = mysqlmanager-pwgen.c
mysqltestmanagerc_SOURCES= mysqlmanagerc.c $(yassl_dummy_link_fix)
mysqlcheck_SOURCES= mysqlcheck.c $(yassl_dummy_link_fix)