summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorunknown <monty@narttu.mysql.fi>2003-05-06 01:38:38 +0300
committerunknown <monty@narttu.mysql.fi>2003-05-06 01:38:38 +0300
commitb96aaea7e15642a8f0d9a478e9daabe470cb966d (patch)
treee4e5fa90d35bf2fc106cf0b773a29900579c7daa /client/Makefile.am
parent03c1ec3d685b60d04b0db274c5201149322ac667 (diff)
downloadmariadb-git-b96aaea7e15642a8f0d9a478e9daabe470cb966d.tar.gz
Removed compiler warnings
Fixed memory leak in new filesort code Optimzed sub selects to use keys with outer references. Increased max tables in join to 62 client/Makefile.am: Remve test programs myisam/mi_check.c: Remove compiler warnings myisam/mi_delete.c: Remove 'rnd' variable to make usage repeatable myisam/mi_open.c: Remove 'rnd' variable to make usage repeatable myisam/mi_write.c: Remove 'rnd' variable to make usage repeatable myisam/myisamdef.h: Remove 'rnd' variable to make usage repeatable myisam/myisamlog.c: Remove 'rnd' variable to make usage repeatable mysql-test/r/subselect.result: new test mysql-test/t/join.test: Updated test mysql-test/t/subselect.test: new test sql/filesort.cc: Added function to free buffers allocated by filesort sql/item.cc: Sub select optimization sql/item_cmpfunc.cc: Sub select optimization sql/item_subselect.cc: Sub select optimization sql/item_sum.cc: Removed compiler warnings sql/item_sum.h: Simple code cleanup sql/log.cc: Removed compiler warning sql/mysql_priv.h: Made table_map ulonglong to allow 62 tables in join sql/records.cc: Moved free of filesort buffers to own function sql/sql_select.cc: subselect optimization Call filesort_free_buffers() to free memory from filesort sql/unireg.h: Sub select optimization
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index da401dd502e..2922b1fc6a2 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -22,7 +22,6 @@ LIBS = @CLIENT_LIBS@
LDADD = @CLIENT_EXTRA_LDFLAGS@ ../libmysql/libmysqlclient.la
bin_PROGRAMS = mysql mysqladmin mysqlcheck mysqlshow \
mysqldump mysqlimport mysqltest mysqlbinlog mysqlmanagerc mysqlmanager-pwgen
-noinst_PROGRAMS = insert_test select_test thread_test
noinst_HEADERS = sql_string.h completion_hash.h my_readline.h \
client_priv.h
mysql_SOURCES = mysql.cc readline.cc sql_string.cc completion_hash.cc