summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorholyfoot@deer.(none) <>2006-04-28 09:07:25 +0500
committerholyfoot@deer.(none) <>2006-04-28 09:07:25 +0500
commit5a75f865c2b70c8ea72d2fa4c344ed395c4ab4a4 (patch)
treec0e0a652c3357f1581b8835382508b5adf547d01 /client/Makefile.am
parent46ee4ea0dffdeb4121fc34de3f930fb29276866b (diff)
downloadmariadb-git-5a75f865c2b70c8ea72d2fa4c344ed395c4ab4a4.tar.gz
bug #18115 (mysql_upgrade on Windows)
pushed in 5.0
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 2c513d3d7c7..9d133125a0d 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -31,6 +31,7 @@ LDADD= @CLIENT_EXTRA_LDFLAGS@ \
$(top_builddir)/libmysql/libmysqlclient.la
bin_PROGRAMS = mysql mysqladmin mysqlcheck mysqlshow \
mysqldump mysqlimport mysqltest mysqlbinlog \
+ mysql_upgrade \
mysqltestmanagerc mysqltestmanager-pwgen
noinst_HEADERS = sql_string.h completion_hash.h my_readline.h \
client_priv.h
@@ -48,11 +49,14 @@ mysqlcheck_SOURCES= mysqlcheck.c $(yassl_dummy_link_fix)
mysqlshow_SOURCES= mysqlshow.c $(yassl_dummy_link_fix)
mysqldump_SOURCES= mysqldump.c my_user.c $(yassl_dummy_link_fix)
mysqlimport_SOURCES= mysqlimport.c $(yassl_dummy_link_fix)
+mysql_upgrade_SOURCES= mysql_upgrade.c $(yassl_dummy_link_fix)
sql_src=log_event.h mysql_priv.h log_event.cc my_decimal.h my_decimal.cc
strings_src=decimal.c
# Fix for mit-threads
-DEFS = -DUNDEF_THREADS_HACK
+DEFS = -DUNDEF_THREADS_HACK \
+ -DDEFAULT_MYSQL_HOME="\"$(prefix)\"" \
+ -DDATADIR="\"$(localstatedir)\""
link_sources:
for f in $(sql_src) ; do \