summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorJim Winstead <jimw@mysql.com>2009-05-12 10:45:40 -0700
committerJim Winstead <jimw@mysql.com>2009-05-12 10:45:40 -0700
commiteae91cc7810c53536423d450b318824e0e96ace0 (patch)
treef848a14af2029be43e21226c8343bf8b6791d7a6 /client/Makefile.am
parent99794e880121f4babaf33eb5851410a0919eeaa7 (diff)
downloadmariadb-git-eae91cc7810c53536423d450b318824e0e96ace0.tar.gz
mysqlimport was not always compiled correctly to allow thread support,
required for the --use-threads option. (Bug #32991)
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 94db565ba37..ab5bc8d601a 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -71,7 +71,7 @@ mysqldump_SOURCES= mysqldump.c \
$(top_srcdir)/mysys/mf_getdate.c
mysqlimport_SOURCES= mysqlimport.c
-
+mysqlimport_CFLAGS= -DTHREAD -UUNDEF_THREADS_HACK
mysqlimport_LDADD = $(CXXLDFLAGS) $(CLIENT_THREAD_LIBS) \
@CLIENT_EXTRA_LDFLAGS@ \
$(LIBMYSQLCLIENT_LA) \