summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorbrian@zim.(none) <>2005-12-28 18:41:06 -0800
committerbrian@zim.(none) <>2005-12-28 18:41:06 -0800
commitf5563028d32f5baa9fa4df89f0e9e38fce9471ce (patch)
treef800c48cf9de5e2352f31a8b9d176ed2736ae0df /client/Makefile.am
parent88bcd74d768225935bb02c99629c76cc9ca90f93 (diff)
downloadmariadb-git-f5563028d32f5baa9fa4df89f0e9e38fce9471ce.tar.gz
Added option --lock-directory so that you can now syncronize several mysqlslap processes across several machines. Not perfect yet.
Added --slave option if you are trying to syncronize around one server using the lock-directory option plus NFS. Added options to allow you to run several concurrency runs in one call. aka --concurrency="1, 8, 64, 128" Time collection is now done in a finer grain manner, and is linked to the sync call (doesn't count the cost of the blocked processes that are setup to run).
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index fe3620bbad7..8b6da68a659 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -52,7 +52,9 @@ mysqltestmanager_pwgen_SOURCES = mysqlmanager-pwgen.c
mysqltestmanagerc_SOURCES= mysqlmanagerc.c $(yassl_dummy_link_fix)
mysqlcheck_SOURCES= mysqlcheck.c $(yassl_dummy_link_fix)
mysqlshow_SOURCES= mysqlshow.c $(yassl_dummy_link_fix)
-mysqlslap_SOURCES= mysqlslap.c $(yassl_dummy_link_fix)
+mysqlslap_SOURCES= mysqlslap.c $(top_srcdir)/mysys/my_lock.c \
+ $(top_srcdir)/mysys/my_alarm.c \
+ $(yassl_dummy_link_fix)
mysqldump_SOURCES= mysqldump.c $(yassl_dummy_link_fix)
mysqlimport_SOURCES= mysqlimport.c $(yassl_dummy_link_fix)
sql_src=log_event.h mysql_priv.h log_event.cc my_decimal.h my_decimal.cc