summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@pilot.blaudden>2007-03-27 23:56:48 +0200
committerunknown <msvensson@pilot.blaudden>2007-03-27 23:56:48 +0200
commitc2d2ede33c4c67258676f26f7030ee3d79be5ef2 (patch)
tree02a7e0d66c1854e1350626ab89132b36162066bd /client/Makefile.am
parent094db7029ea92e7dc6c0731e5e6f19285f415536 (diff)
downloadmariadb-git-c2d2ede33c4c67258676f26f7030ee3d79be5ef2.tar.gz
Bug#22508 BUILD/compile-dist fails due to problem with readline/libedit
- Move the link_sources command from top level Makefile into each subdir that need to link files BitKeeper/etc/ignore: Added libmysqld/link_sources libmysql/link_sources include/link_sources client/link_sources to the ignore list Makefile.am: Move link_sources down into each sub directory that might need it client/Makefile.am: Add "link_sources" to BUILT_SOURCES configure.in: Move link_sources down into each sub directory that might need it include/Makefile.am: Add "link_sources" to BUILT_SOURCES libmysql/Makefile.am: Add "link_sources" to BUILT_SOURCES libmysql/Makefile.shared: Add "link_sources" to BUILT_SOURCES libmysqld/Makefile.am: Add "link_sources" to BUILT_SOURCES libmysqld/examples/Makefile.am: Add "link_sources" to BUILT_SOURCES netware/Makefile.am: Add "link_sources" to BUILT_SOURCES sql/Makefile.am: Add "link_sources" to BUILT_SOURCES
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 747b27e9aa0..c2993c5a0d5 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -36,6 +36,10 @@ noinst_HEADERS = sql_string.h completion_hash.h my_readline.h \
EXTRA_DIST = get_password.c CMakeLists.txt
+BUILT_SOURCES = link_sources
+
+CLEANFILES = $(BUILT_SOURCES)
+
bin_PROGRAMS = mysql \
mysqladmin \
mysqlbinlog \
@@ -108,6 +112,7 @@ link_sources:
done; \
rm -f $(srcdir)/my_user.c; \
@LN_CP_F@ $(top_srcdir)/sql-common/my_user.c my_user.c;
+ echo timestamp > link_sources;
# Don't update the files from bitkeeper
%::SCCS/s.%