summaryrefslogtreecommitdiff
path: root/cmake/Makefile.am
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@sun.com>2010-02-24 20:07:05 +0100
committerVladislav Vaintroub <wlad@sun.com>2010-02-24 20:07:05 +0100
commitbcebd97306a7d3fd16c91ed140745183f3d801f0 (patch)
tree2e29009b44c812bb70b481cc228a6b2fff4557dc /cmake/Makefile.am
parent60c7cc878f284b9855cbb110e0aa425f38e5d0e8 (diff)
downloadmariadb-git-bcebd97306a7d3fd16c91ed140745183f3d801f0.tar.gz
#51466 : Source packages are broken with cmake in a cmake-agnostic environment
In the worst case possible scenario (no bzr, in-source build), make dist produced a package that compiled ok with autotools but failed to package because extra make_binary_distribution was found in source package and was not built. make_binary_distribution contained paths of the build machine. Fix: exclude some scripts that are produced in cmake build. Note that there is no good general fix for it in this specific scenario. it is advisable to build source packages out of source or in bzr repo.
Diffstat (limited to 'cmake/Makefile.am')
-rw-r--r--cmake/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cmake/Makefile.am b/cmake/Makefile.am
index 334c9fc7a0e..6fe1a9556be 100644
--- a/cmake/Makefile.am
+++ b/cmake/Makefile.am
@@ -1,5 +1,6 @@
EXTRA_DIST = \
cmake_parse_arguments.cmake \
+ cpack_source_ignore_files.cmake \
package_name.cmake \
configurable_file_content.in \
check_minimal_version.cmake \