summaryrefslogtreecommitdiff
path: root/cmd-line-utils/libedit/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-07-30 21:09:45 +0200
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-07-30 21:09:45 +0200
commit16ff419b8ae86ccbf017d19ee00141e3e1c05988 (patch)
treed7889999d2852a9bed51f043da21bf534596a6c2 /cmd-line-utils/libedit/Makefile.am
parentc7e8135dfdef6502c8e310a77ae1b986fcdcbffd (diff)
downloadmariadb-git-16ff419b8ae86ccbf017d19ee00141e3e1c05988.tar.gz
Generate "config.h" directly into the "include" directory, later copied
to "my_config.h". Not to pollute the top directory, and to get more control over what is included. Made the include path for "libedit" pick up its own "config.h" first. config/ac-macros/misc.m4: aclocal in automake 1.8 can't handle AC_REQUIRE on a user macro defined in the same included file. cmd-line-utils/libedit/Makefile.am: Changed include path so that current directory is taken first, as there is a "config.h" there with the same name as the one in top "include". configure.in: Generate "config.h" directly into "include", don't pollute top directory include/Makefile.am: Copy "config.h" from current directory to "my_config.h", added note in the make file why there are two identical files with different name. scripts/make_binary_distribution.sh: Removed copy of "config.h" from top directory, it is in "include" in a source tree.
Diffstat (limited to 'cmd-line-utils/libedit/Makefile.am')
-rw-r--r--cmd-line-utils/libedit/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/cmd-line-utils/libedit/Makefile.am b/cmd-line-utils/libedit/Makefile.am
index ae6755f1c5c..b7611193aea 100644
--- a/cmd-line-utils/libedit/Makefile.am
+++ b/cmd-line-utils/libedit/Makefile.am
@@ -5,8 +5,8 @@
ASRC = $(srcdir)/vi.c $(srcdir)/emacs.c $(srcdir)/common.c
AHDR = vi.h emacs.h common.h
-INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include \
- -I$(srcdir)/../.. -I..
+# Make sure to include stuff from this directory first, to get right "config.h"
+INCLUDES = -I. -I$(top_builddir)/include -I$(top_srcdir)/include
noinst_LIBRARIES = libedit.a