summaryrefslogtreecommitdiff
path: root/cmd-line-utils/libedit/Makefile.am
diff options
context:
space:
mode:
authorunknown <vva@eagle.mysql.r18.ru>2004-09-03 17:47:36 +0500
committerunknown <vva@eagle.mysql.r18.ru>2004-09-03 17:47:36 +0500
commit37aad6bb4f4c4743a42646af21086e91046fb369 (patch)
tree38a056e0d57bb147fc5d54ff64a3e78a30e05313 /cmd-line-utils/libedit/Makefile.am
parent52df5f5b5a0edfb5512957eb8aa6cd6c3c53b4a5 (diff)
downloadmariadb-git-37aad6bb4f4c4743a42646af21086e91046fb369.tar.gz
1. discarded term.h from the distribution
2. changed key_* to el_ley_* in the libedit key.h (because it's in the conflict with the aix definitions) 3. use libedit_term.h instead of term.h in the cmd-line-utils/libedit/el.h 4. added definition of MIN in the cmd-line-utils/libedit/read.c (if it wasn't defined yet) 5. discarded definition of SUNOS macro from configure.in (now we don't include term.h in the el.h at all) BitKeeper/deleted/.del-term.h~23716a5310508e0: Delete: cmd-line-utils/libedit/term.h cmd-line-utils/libedit/Makefile.am: discarded term.h from the distribution cmd-line-utils/libedit/el.c: changed key_init -> el_key_init key_end -> el_key_end cmd-line-utils/libedit/el.h: change #include "term.h" to #include "libedit_term.h" cmd-line-utils/libedit/key.c: changed functions key_... to el_key_... because it's in conflict with the aix definitions cmd-line-utils/libedit/key.h: changed functions key_... to el_key_... because it's in conflict with the aix definitions cmd-line-utils/libedit/map.c: changed functions key_... to el_key_... because it's in conflict with the aix definitions cmd-line-utils/libedit/read.c: 1. added definition of MIN 2. fixed problems with undefined uint 3. changed key_get to el_key_get cmd-line-utils/libedit/term.c: 1. discarded #include "term.h" at all 2. changed functions key_* to el_key_* 3. add declaration of el_key__decode_str cmd-line-utils/libedit/tty.c: changed functions key_... to el_key_... because it's in conflict with the aix definitions configure.in: discarded definition of SUNOS macro (libedit doesn't require it anymore)
Diffstat (limited to 'cmd-line-utils/libedit/Makefile.am')
-rw-r--r--cmd-line-utils/libedit/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cmd-line-utils/libedit/Makefile.am b/cmd-line-utils/libedit/Makefile.am
index c6f9ccf06ff..a3d73a7082a 100644
--- a/cmd-line-utils/libedit/Makefile.am
+++ b/cmd-line-utils/libedit/Makefile.am
@@ -24,7 +24,7 @@ pkginclude_HEADERS = readline/readline.h
noinst_HEADERS = chared.h el.h histedit.h key.h parse.h refresh.h sig.h \
sys.h tokenizer.h config.h hist.h map.h prompt.h read.h \
- search.h tty.h libedit_term.h term.h
+ search.h tty.h libedit_term.h
EXTRA_DIST = makelist.sh np/unvis.c np/strlcpy.c np/vis.c np/vis.h np/strlcat.c np/fgetln.c