summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <SergeyV@selena.>2006-01-20 18:40:02 +0300
committerunknown <SergeyV@selena.>2006-01-20 18:40:02 +0300
commit61946d225a0d8a7e941bc00395391ef9b9f47efe (patch)
tree5c8dacf57abe3abd01d2b44332a2e9efebc3c562 /configure.in
parentb045ee329765231d8fcfc722fc87d2cc18f6643b (diff)
parent94ea98832aeff8854090ddb6d64886b648ddccc7 (diff)
downloadmariadb-git-61946d225a0d8a7e941bc00395391ef9b9f47efe.tar.gz
Merge svlasenko@bk-internal.mysql.com:/home/bk/mysql-5.1-new
into selena.:H:/MYSQL/src/#00000-mysql-5.1 client/mysqlslap.c: Auto merged configure.in: Auto merged VC++Files/mysql.sln: manual merge
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ad31ec8a497..ffc311a7857 100644
--- a/configure.in
+++ b/configure.in
@@ -1420,6 +1420,7 @@ AC_MSG_CHECKING("named thread libs:")
if test "$with_named_thread" != "no"
then
LIBS="$with_named_thread $LIBS $with_named_thread"
+ CLIENT_THREAD_LIBS="$with_named_thread"
with_posix_threads="yes"
AC_MSG_RESULT("$with_named_thread")
else
@@ -1436,6 +1437,7 @@ else
AC_MSG_CHECKING("for pthread_create in -lpthread");
ac_save_LIBS="$LIBS"
LIBS="$LIBS -lpthread"
+ CLIENT_THREAD_LIBS="-lpthread"
AC_TRY_LINK(
[#include <pthread.h>],
[ (void) pthread_create((pthread_t*) 0,(pthread_attr_t*) 0, 0, 0); ],
@@ -1444,6 +1446,7 @@ else
if test "$with_posix_threads" = "no"
then
LIBS=" $ac_save_LIBS -lpthreads"
+ CLIENT_THREAD_LIBS="-lpthreads"
AC_MSG_CHECKING("for pthread_create in -lpthreads");
AC_TRY_LINK(
[#include <pthread.h>],
@@ -1454,6 +1457,7 @@ else
then
# This is for FreeBSD
LIBS="$ac_save_LIBS -pthread"
+ CLIENT_THREAD_LIBS="-pthread"
AC_MSG_CHECKING("for pthread_create in -pthread");
AC_TRY_LINK(
[#include <pthread.h>],
@@ -2470,6 +2474,7 @@ fi
CLIENT_LIBS="$NON_THREADED_LIBS $openssl_libs $ZLIB_LIBS $STATIC_NSS_FLAGS"
AC_SUBST(CLIENT_LIBS)
+AC_SUBST(CLIENT_THREAD_LIBS)
AC_SUBST(NON_THREADED_LIBS)
AC_SUBST(STATIC_NSS_FLAGS)
AC_SUBST(sql_client_dirs)