summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <vva@eagle.mysql.r18.ru>2004-08-24 19:23:23 +0500
committerunknown <vva@eagle.mysql.r18.ru>2004-08-24 19:23:23 +0500
commitde225e637a65366aab0ad5fd8b08f24af8ee8f67 (patch)
tree9448cab63e74b61a56dbd133d3ef099a5244f068 /configure.in
parent83e3d3f9a3ab6888292b8bcb15e0f77f00249289 (diff)
downloadmariadb-git-de225e637a65366aab0ad5fd8b08f24af8ee8f67.tar.gz
fixed :
Bug #3937 fails to compile with both gcc 3.3.3/icc8 Bug #4728 mysql couldn't be compiled using system readline (readline-4.3) acinclude.m4: 1. added defun MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY for last versions of readline and libedit 2. added #undef __P in defuns MYSQL_CHECK_LIBEDIT_INTERFACE, MYSQL_CHECK_NEW_RL_INTERFACE client/mysql.cc: 1. added #undef __P before #include "readline/readline.h" because readline-4.2 declares own __P 2. changed !defined(USE_LIBEDIT_INTERFACE) to !defined(HAVE_HIST_ENTRY) before declaring of own hist_entry because latest versions of libedit declare hist_entry too cmd-line-utils/Makefile.am: added copyright header configure.in: 1. added comment for --with-readline/--with-libedit options 2. added define for HAVE_HIST_ENTRY and macro to check it 3. added AC_LANG_CPLUSPLUS before readline/libedit checks
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 664ffd2a4a1..288454d2c6c 100644
--- a/configure.in
+++ b/configure.in
@@ -2303,6 +2303,20 @@ AC_ARG_WITH(libedit,
[ with_libedit=undefined ]
)
+#
+# We support next variants of compilation:
+# --with-readline
+# | yes | no | undefined
+# --with-libedit | | |
+# ---------------+----------------+------+----------------------------------
+# yes | ERROR! | use libedit from mysql sources
+# ---------------+----------------+------+----------------------------------
+# no | use readline | use system readline or external libedit
+# | from mysql | according to results of m4 tests
+# ---------------+ sources (if it + +----------------------------------
+# undefined | is presented) | | use libedit from mysql sources
+
+
compile_readline="no"
compile_libedit="no"
@@ -2330,6 +2344,7 @@ then
readline_link="\$(top_builddir)/cmd-line-utils/libedit/liblibedit.a"
readline_h_ln_cmd="\$(LN) -s \$(top_builddir)/cmd-line-utils/libedit/readline readline"
compile_libedit=yes
+ AC_DEFINE_UNQUOTED(HAVE_HIST_ENTRY)
AC_DEFINE_UNQUOTED(USE_LIBEDIT_INTERFACE, 1)
elif test "$with_readline" = "yes"
then
@@ -2341,8 +2356,12 @@ then
compile_readline=yes
AC_DEFINE_UNQUOTED(USE_NEW_READLINE_INTERFACE, 1)
else
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
MYSQL_CHECK_LIBEDIT_INTERFACE
MYSQL_CHECK_NEW_RL_INTERFACE
+ MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY
+ AC_LANG_RESTORE
if [test "$mysql_cv_new_rl_interface" = "yes"] || [test "$mysql_cv_libedit_interface" = "no"]
then
readline_link="-lreadline"