summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorlenz@mysql.com <>2002-11-21 22:14:57 +0100
committerlenz@mysql.com <>2002-11-21 22:14:57 +0100
commitfd79ed87b50856fa7db8f5fafcc326b063b52239 (patch)
treee59f3fef4c087ad4bc6ca3d9feaf2634671cfe5d /configure.in
parent373904f7991d806d94f1ac2ec592d77bbcf22906 (diff)
downloadmariadb-git-fd79ed87b50856fa7db8f5fafcc326b063b52239.tar.gz
configure.in:
- actually follow the hints in the comment above and "Remember that regexps needs to quote [ and ] since this is run through m4"...
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4dfee69f1c0..9b70e81d088 100644
--- a/configure.in
+++ b/configure.in
@@ -15,7 +15,7 @@ SHARED_LIB_VERSION=11:0:0
# Set all version vars based on $VERSION. How do we do this more elegant ?
# Remember that regexps needs to quote [ and ] since this is run through m4
MYSQL_NO_DASH_VERSION=`echo $VERSION | sed -e "s|-.*$||"`
-MYSQL_NO_DASH_VERSION=`echo $VERSION | sed -e "s|[a-z]*-.*$||"`
+MYSQL_NO_DASH_VERSION=`echo $VERSION | sed -e "s|[[a-z]]*-.*$||"`
MYSQL_BASE_VERSION=`echo $MYSQL_NO_DASH_VERSION | sed -e "s|\.[[^.]]*$||"`
F_PART=`echo $MYSQL_BASE_VERSION | sed -e "s|\.||g"| sed -e "s|[a-zA-Z]\+||"|sed -e "s|^\(..\)$|\\10|"`
L_PART=`echo $MYSQL_NO_DASH_VERSION | sed -e "s|^[[0-9]]\.[[0-9]]*\.||" | sed -e "s|^\(.\)$|0\\1|" | sed -e "s|[[a-z]]||"`