summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@threads.polyesthetic.msg>2001-03-07 16:34:42 -0500
committerunknown <tim@threads.polyesthetic.msg>2001-03-07 16:34:42 -0500
commitb0089e699a4ed1c9287726185835d701a297cfd6 (patch)
tree553dd04d6fbda617f3a48f0ecefef351047835bd /configure.in
parent277d59b86e14fc5443bc5a87fc399ee2d5491069 (diff)
downloadmariadb-git-b0089e699a4ed1c9287726185835d701a297cfd6.tar.gz
Changes so that 'make distcheck' works with Berkeley DB.
Build-tools/Do-all-build-steps: We now build with Berkeley DB. Docs/manual.texi: Try to make MySQL's extensions to GROUP BY more noticable. acinclude.m4: Berkeley DB defaults to "no", now. Changes so that 'make distcheck' works with Berkeley DB. bdb/Makefile.in: Add some more dummy targets to ignore.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 25 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 1bac02c3591..1939f6191d1 100644
--- a/configure.in
+++ b/configure.in
@@ -1877,9 +1877,31 @@ then
then
bdb_conf_flags="$bdb_conf_flags --enable-debug --enable-diagnostic"
fi
- (cd $bdb && cd build_unix && sh ../dist/configure $bdb_conf_flags) \
- || AC_MSG_ERROR([could not configure Berkeley DB])
-
+ # NOTICE: if you're compiling BDB, it needs to be a SUBDIR
+ # of $srcdir (i.e., you can 'cd $srcdir/$bdb'). It won't
+ # work otherwise.
+ if test -d "$bdb"; then :
+ else
+ # This should only happen when doing a VPATH build
+ echo "NOTICE: I have to make the BDB directory: `pwd`:$bdb"
+ mkdir "$bdb" || exit 1
+ fi
+ if test -d "$bdb"/build_unix; then :
+ else
+ # This should only happen when doing a VPATH build
+ echo "NOTICE: I have to make the build_unix directory: `pwd`:$bdb/build_unix"
+ mkdir "$bdb/build_unix" || exit 1
+ fi
+ rel_srcdir=
+ case "$srcdir" in
+ /* ) rel_srcdir="$srcdir" ;;
+ * ) rel_srcdir="../../$srcdir" ;;
+ esac
+ (cd $bdb/build_unix && \
+ sh $rel_srcdir/$bdb/dist/configure $bdb_conf_flags) || \
+ AC_MSG_ERROR([could not configure Berkeley DB])
+
+dnl echo "bdb = '$bdb'; inc = '$bdb_includes', lib = '$bdb_libs'"
echo "END OF BERKELEY DB CONFIGURATION"
fi