summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <mtaylor@qualinost.(none)>2007-01-18 16:31:43 -0800
committerunknown <mtaylor@qualinost.(none)>2007-01-18 16:31:43 -0800
commitf218118f23d9ee04760b7b79737d6939517306ed (patch)
tree517767c222f79290283d431ce1a2da070213c6fc /configure.in
parent9f8ce6f017e7f39ad704a57bf0e4f6784e61121a (diff)
downloadmariadb-git-f218118f23d9ee04760b7b79737d6939517306ed.tar.gz
Add code to actually version the symbols in the library, and not just the library. bug #13522
storage/ndb/src/libndb.ver.in: BitKeeper file /home/mtaylor/src/mysql-5.1-new-maint/storage/ndb/src/libndb.ver.in
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 17a9714c16c..0becfe00bd5 100644
--- a/configure.in
+++ b/configure.in
@@ -15,6 +15,8 @@ DOT_FRM_VERSION=6
# See the libtool docs for information on how to do shared lib versions.
SHARED_LIB_MAJOR_VERSION=15
SHARED_LIB_VERSION=$SHARED_LIB_MAJOR_VERSION:0:0
+NDB_SHARED_LIB_MAJOR_VERSION=3
+NDB_SHARED_LIB_VERSION=$NDB_SHARED_LIB_MAJOR_VERSION:0:0
# Set all version vars based on $VERSION. How do we do this more elegant ?
# Remember that regexps needs to quote [ and ] since this is run through m4
MYSQL_NO_DASH_VERSION=`echo $VERSION | sed -e "s|[[a-z]]*-.*$||"`
@@ -58,6 +60,8 @@ AC_DEFINE_UNQUOTED([DOT_FRM_VERSION], [$DOT_FRM_VERSION],
[Version of .frm files])
AC_SUBST(SHARED_LIB_MAJOR_VERSION)
AC_SUBST(SHARED_LIB_VERSION)
+AC_SUBST(NDB_SHARED_LIB_MAJOR_VERSION)
+AC_SUBST(NDB_SHARED_LIB_VERSION)
AC_SUBST(AVAILABLE_LANGUAGES)
@@ -354,6 +358,14 @@ if $LD --version 2>/dev/null|grep -q GNU; then
fi
AC_SUBST(LD_VERSION_SCRIPT)
+# libndbclient versioning when linked with GNU ld.
+if $LD --version 2>/dev/null|grep -q GNU; then
+ NDB_LD_VERSION_SCRIPT="-Wl,--version-script=\$(top_builddir)/storage/ndb/src/libndb.ver"
+ AC_CONFIG_FILES(storage/ndb/src/libndb.ver)
+fi
+AC_SUBST(NDB_LD_VERSION_SCRIPT)
+
+
# Avoid bug in fcntl on some versions of linux
AC_MSG_CHECKING([if we should use 'skip-external-locking' as default for $target_os])
# Any variation of Linux