summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <SergeyV@selena.>2006-01-16 17:28:24 +0300
committerunknown <SergeyV@selena.>2006-01-16 17:28:24 +0300
commitacbe66e6db76ec606d2337f24a5df9ebd4683ada (patch)
treec3175212314d812f7e010fa4a6173e2a95f26b7d /configure.in
parent99ebd49555bd1993ccb3745eb3b55f4ea38ec49d (diff)
downloadmariadb-git-acbe66e6db76ec606d2337f24a5df9ebd4683ada.tar.gz
Fixes problem introduced by non-portable thread library definition in client
makefile.am. Instead of adding lpthread directly it is added $CLIENT_THREAD_LIBS, which is evaluated during configure. client/Makefile.am: Added portable definition of thread libs in client makefile.am configure.in: Added portable definition of thread libs for client makefile.am
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e8256a5a526..e10d4ed451d 100644
--- a/configure.in
+++ b/configure.in
@@ -1420,6 +1420,7 @@ AC_MSG_CHECKING("named thread libs:")
if test "$with_named_thread" != "no"
then
LIBS="$with_named_thread $LIBS $with_named_thread"
+ CLIENT_THREAD_LIBS="$with_named_thread"
with_posix_threads="yes"
AC_MSG_RESULT("$with_named_thread")
else
@@ -1436,6 +1437,7 @@ else
AC_MSG_CHECKING("for pthread_create in -lpthread");
ac_save_LIBS="$LIBS"
LIBS="$LIBS -lpthread"
+ CLIENT_THREAD_LIBS="-lpthread"
AC_TRY_LINK(
[#include <pthread.h>],
[ (void) pthread_create((pthread_t*) 0,(pthread_attr_t*) 0, 0, 0); ],
@@ -1444,6 +1446,7 @@ else
if test "$with_posix_threads" = "no"
then
LIBS=" $ac_save_LIBS -lpthreads"
+ CLIENT_THREAD_LIBS="-lpthreads"
AC_MSG_CHECKING("for pthread_create in -lpthreads");
AC_TRY_LINK(
[#include <pthread.h>],
@@ -1454,6 +1457,7 @@ else
then
# This is for FreeBSD
LIBS="$ac_save_LIBS -pthread"
+ CLIENT_THREAD_LIBS="-pthread"
AC_MSG_CHECKING("for pthread_create in -pthread");
AC_TRY_LINK(
[#include <pthread.h>],
@@ -2469,6 +2473,7 @@ fi
CLIENT_LIBS="$NON_THREADED_LIBS $openssl_libs $ZLIB_LIBS $STATIC_NSS_FLAGS"
AC_SUBST(CLIENT_LIBS)
+AC_SUBST(CLIENT_THREAD_LIBS)
AC_SUBST(NON_THREADED_LIBS)
AC_SUBST(STATIC_NSS_FLAGS)
AC_SUBST(sql_client_dirs)