summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <konstantin@mysql.com>2005-01-28 01:23:06 +0300
committerunknown <konstantin@mysql.com>2005-01-28 01:23:06 +0300
commitb485ed7b49f25617efc7070032187335216b7a9c (patch)
tree83fc7d2662df26a52d86fa6b197824b3f283d982 /configure.in
parenta271a6c878ffe8245bd631888bfeee3cb5055005 (diff)
downloadmariadb-git-b485ed7b49f25617efc7070032187335216b7a9c.tar.gz
Remove unused configure.in name TOOLS_LIBS.
configure.in: Remove unused TOOLS_LIBS: LIBS and CLIENT_LIBS should be enough for the global configure.in
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 985b5923c5c..98d060e660c 100644
--- a/configure.in
+++ b/configure.in
@@ -1536,14 +1536,11 @@ then
fi
fi
-TOOLS_LIBS="$NON_THREADED_CLIENT_LIBS"
-
# Should we use named pthread library ?
AC_MSG_CHECKING("named thread libs:")
if test "$with_named_thread" != "no"
then
LIBS="$with_named_thread $LIBS $with_named_thread"
- TOOLS_LIBS="$with_named_thread $TOOLS_LIBS $with_named_thread"
with_posix_threads="yes"
with_mit_threads="no"
AC_MSG_RESULT("$with_named_thread")
@@ -1562,9 +1559,7 @@ else
then
AC_MSG_CHECKING("for pthread_create in -lpthread");
ac_save_LIBS="$LIBS"
- ac_save_TOOLS_LIBS="$TOOLS_LIBS"
LIBS="$LIBS -lpthread"
- TOOLS_LIBS="$TOOLS_LIBS -lpthread"
AC_TRY_LINK(
[#include <pthread.h>],
[ (void) pthread_create((pthread_t*) 0,(pthread_attr_t*) 0, 0, 0); ],
@@ -1573,7 +1568,6 @@ else
if test "$with_posix_threads" = "no"
then
LIBS=" $ac_save_LIBS -lpthreads"
- TOOLS_LIBS=" $ac_save_TOOLS_LIBS -lpthreads"
AC_MSG_CHECKING("for pthread_create in -lpthreads");
AC_TRY_LINK(
[#include <pthread.h>],
@@ -1584,7 +1578,6 @@ else
then
# This is for FreeBSD
LIBS="$ac_save_LIBS -pthread"
- TOOLS_LIBS="$ac_save_TOOLS_LIBS -pthread"
AC_MSG_CHECKING("for pthread_create in -pthread");
AC_TRY_LINK(
[#include <pthread.h>],
@@ -1595,7 +1588,6 @@ else
then
with_mit_threads="yes"
LIBS="$ac_save_LIBS"
- TOOLS_LIBS="$ac_save_TOOLS_LIBS"
fi
fi
fi
@@ -3037,8 +3029,6 @@ AC_SUBST(sql_union_dirs)
# Some usefull subst
AC_SUBST(CC)
AC_SUBST(GXX)
-#Remove TOOLS_LIBS, because this is included in LIBRARIES
-#AC_SUBST(TOOLS_LIBS)
# Set configuration options for make_binary_distribution
case $SYSTEM_TYPE in