summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormonty@narttu.mysql.fi <>2003-07-04 03:18:15 +0300
committermonty@narttu.mysql.fi <>2003-07-04 03:18:15 +0300
commitf3af0d7ce423d3b28de463c430f4ff4bef8b925e (patch)
treeeaf3cc9d9913bdfe213c549f3890aa25f565ca8b /configure.in
parent3f4f339f15748a348d085da9c3d17658d01b4af3 (diff)
downloadmariadb-git-f3af0d7ce423d3b28de463c430f4ff4bef8b925e.tar.gz
Status query on killed mysql connection results in segmentation fault (Bug #738)
Added MAX_PASSWORD_LENGTH. This increased master-slave passwords to 32 bytes (Bug #766) Fixed server crash on purge master logs or show master logs when binlog is off. (Bug #733)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 12 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index a33ccd4a311..38847b5217e 100644
--- a/configure.in
+++ b/configure.in
@@ -1282,12 +1282,12 @@ then
AC_MSG_ERROR([On SCO UNIX MySQL must be compiled with gcc. See the Installation chapter in the Reference Manual.]);
fi
AC_MSG_RESULT("yes")
- # Hack for SCO UnixWare 7.1
+ # Hack for SCO UnixWare 7.1.x
#
elif test "$with_named_thread" = "no"
then
AC_MSG_RESULT("no")
- AC_MSG_CHECKING("SCO UnixWare 7.1 native threads")
+ AC_MSG_CHECKING("SCO UnixWare 7.1.x native threads")
if expr "$SYSTEM_TYPE" : ".*sco.*" > /dev/null
then
if test -f /usr/lib/libthread.so -o -f /usr/lib/libthreadT.so
@@ -1310,11 +1310,11 @@ then
AC_MSG_CHECKING("for gcc")
if expr "$CC" : ".*gcc.*"
then
- CC="$CC -pthread -DUNIXWARE_7";
- CXX="$CXX -pthread -DUNIXWARE_7";
+ CC="$CC -pthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";
+ CXX="$CXX -pthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";
else
- CC="$CC -Kthread -DUNIXWARE_7";
- CXX="$CXX -Kthread -DUNIXWARE_7";
+ CC="$CC -Kthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";
+ CXX="$CXX -Kthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";
fi
else
{ echo "configure: error: Can't find thread libs on SCO UnixWare7. See the Installation chapter in the Reference Manual." 1>&2; exit 1; };
@@ -1350,10 +1350,11 @@ then
AC_MSG_CHECKING("for gcc")
if expr "$CC" : ".*gcc.*"
then
- { echo "configure: error: On SCO UnixWare7 MySQL must be compiled with cc. See the Installation chapter in the Reference Manual." 1>&2; exit 1; };
+ CC="$CC -pthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";
+ CXX="$CXX -pthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";
else
- CC="$CC -Kthread -DUNIXWARE_7";
- CXX="$CXX -Kthread -DUNIXWARE_7";
+ CC="$CC -Kthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";
+ CXX="$CXX -Kthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";
fi
AC_MSG_RESULT("yes")
else
@@ -1385,7 +1386,8 @@ then
AC_MSG_CHECKING("for gcc")
if expr "$CC" : ".*gcc.*"
then
- { echo "configure: error: On OpenUNIX8 and UnixWare7 MySQL must be compiled with cc. See the Installation chapter in the Reference Manual." 1>&2; exit 1; };
+ CC="$CC -pthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";
+ CXX="$CXX -pthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";
else
CC="$CC -Kthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";
CXX="$CXX -Kthread -DUNIXWARE_7 -DHAVE_BROKEN_RWLOCK";