summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorbell@sanja.is.com.ua <>2006-04-13 15:07:50 +0300
committerbell@sanja.is.com.ua <>2006-04-13 15:07:50 +0300
commitcb81389aef255b606cb262226d2721346ef567e2 (patch)
treed096b4ad76ab8747e5598eb10f6c70cc55978bd0 /configure.in
parent34b2ed5f7f7889eb5f05c5bc8057bf8ae69aa796 (diff)
parentb4980d43830040ae950e36d7dc71398bf613a575 (diff)
downloadmariadb-git-cb81389aef255b606cb262226d2721346ef567e2.tar.gz
Merge sanja.is.com.ua:/home/bell/mysql/bk/mysql-4.1
into sanja.is.com.ua:/home/bell/mysql/bk/work-5.0
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3e936ae422f..174c9a16d8e 100644
--- a/configure.in
+++ b/configure.in
@@ -805,6 +805,9 @@ AC_SUBST(WRAPLIBS)
if test "$TARGET_LINUX" = "true"; then
AC_MSG_CHECKING([for atomic operations])
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+
atom_ops=
AC_TRY_RUN([
#include <asm/atomic.h>
@@ -840,6 +843,8 @@ int main()
if test -z "$atom_ops"; then atom_ops="no"; fi
AC_MSG_RESULT($atom_ops)
+ AC_LANG_RESTORE
+
AC_ARG_WITH(pstack,
[ --with-pstack Use the pstack backtrace library],
[ USE_PSTACK=$withval ],