summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@mysql.com>2004-05-28 02:00:34 +0300
committerunknown <monty@mysql.com>2004-05-28 02:00:34 +0300
commitd1306dfa9df20972f20d1973042e0164a3183919 (patch)
tree0172cde8317cee600aceb317663b2c13ce7701f0 /configure.in
parentb9c825e4a03781dec314923671d6daa9584cbbb1 (diff)
downloadmariadb-git-d1306dfa9df20972f20d1973042e0164a3183919.tar.gz
Portability fix for HPUX
configure.in: Ensure that innodb gets system specific CFLAGS and CXXFLAGS innobase/os/os0file.c: Don't use pread/pwrite on systems where these are not working. This fixes a bug on HPUX, where InnoDB didn't create the ibdata1 file correctly.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 29a887076ac..f2b66d1e09d 100644
--- a/configure.in
+++ b/configure.in
@@ -2484,6 +2484,9 @@ AC_SUBST(netware_dir)
AC_SUBST(linked_netware_sources)
AM_CONDITIONAL(HAVE_NETWARE, test "$netware_dir" = "netware")
+# Ensure that table handlers gets all modifications to CFLAGS/CXXFLAGS
+export CC CXX CFLAGS CXXFLAGS LD LDFLAGS AR
+
if test "$with_server" = "yes" -o "$THREAD_SAFE_CLIENT" != "no"
then
AC_DEFINE(THREAD)