summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@hundin.mysql.fi>2002-03-25 21:23:30 +0200
committerunknown <monty@hundin.mysql.fi>2002-03-25 21:23:30 +0200
commit8bf5ad427cf76dda8e291ef80f48484618d89072 (patch)
tree6c54e4909b254556431f50e070adf08fbf3a4a7a /configure.in
parent739b4da8880a2e6b745f078209cea995c75c2536 (diff)
downloadmariadb-git-8bf5ad427cf76dda8e291ef80f48484618d89072.tar.gz
Print compiler version
Optimize for pentiumpro for RPM's. Build-tools/Do-rpm: Use compiler option -mpentiumpro configure.in: Print compiler version
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 48c12d3b471..03f0d1b16d5 100644
--- a/configure.in
+++ b/configure.in
@@ -126,6 +126,20 @@ AC_PROG_CC
AC_PROG_CXX
AC_PROG_CPP
+# Print version of CC and CXX compiler (if they support --version)
+CC_VERSION=`$CC --version`
+if test $? -eq "0"
+then
+ AC_MSG_CHECKING("C Compiler version of $CC");
+ AC_MSG_RESULT($CC_VERSION)
+fi
+CXX_VERSION=`$CXX --version`
+if test $? -eq "0"
+then
+ AC_MSG_CHECKING("C++ compiler version of $CXX");
+ AC_MSG_RESULT($CXX_VERSION)
+fi
+
# Fix for sgi gcc / sgiCC which tries to emulate gcc
if test "$CC" = "sgicc"
then