summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2005-04-27 11:19:00 +0200
committerunknown <msvensson@neptunus.(none)>2005-04-27 11:19:00 +0200
commitecfae64d65c54004b2330669f141d44e48d4742c (patch)
tree682aab86a033af21a5abb62c54361d069f509618 /configure.in
parent20cf8f82eefbc4db26ec50aef4f602c991811397 (diff)
downloadmariadb-git-ecfae64d65c54004b2330669f141d44e48d4742c.tar.gz
Bug #8162 MySQL cannot be compiled without readline
- Display error if system readline or libedit can't be found configure.in: Display an error if user has selected not to use the bundled libedit or readline, AND the system readline or libedit can't be found
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d191463d0f9..7ef68e2098d 100644
--- a/configure.in
+++ b/configure.in
@@ -2405,17 +2405,24 @@ then
compile_readline=yes
AC_DEFINE_UNQUOTED(USE_NEW_READLINE_INTERFACE, 1)
else
+ # Use system readline library
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
MYSQL_CHECK_LIBEDIT_INTERFACE
MYSQL_CHECK_NEW_RL_INTERFACE
MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY
AC_LANG_RESTORE
- if [test "$mysql_cv_new_rl_interface" = "yes"] || [test "$mysql_cv_libedit_interface" = "no"]
+ if [test "$mysql_cv_new_rl_interface" = "yes"]
then
+ # Use the new readline interface
readline_link="-lreadline"
- else
+ elif [test "$mysql_cv_libedit_interface" = "yes"]; then
+ # Use libedit
readline_link="-ledit"
+ else
+ AC_MSG_ERROR([Could not find system readline or libedit libraries
+ Use --with-readline or --with-libedit to use the bundled
+ versions of libedit or readline])
fi
fi
fi