summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormsvensson@shellback.(none) <>2006-09-12 15:47:48 +0200
committermsvensson@shellback.(none) <>2006-09-12 15:47:48 +0200
commitdf2fbc784d9c634f9b7292da6e843edbc65319ed (patch)
tree565f736e2e9e7cc12c7ec92a8fd2ec0df49a4817 /configure.in
parentb5f67a642fff1a57249100a3d1096a2a0a81c3f8 (diff)
downloadmariadb-git-df2fbc784d9c634f9b7292da6e843edbc65319ed.tar.gz
Bug#14862 undefined reference to `isinf' on SOLARIS - strings/strtod.c
- Change the configure test looking for 'isinf' so the value returned from isinf is used. That avoids the call to isinf being optimized away.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b49dffcb59f..74aff4c6252 100644
--- a/configure.in
+++ b/configure.in
@@ -1946,7 +1946,7 @@ esac
# isinf() could be a function or a macro (HPUX)
AC_MSG_CHECKING(for isinf with <math.h>)
-AC_TRY_LINK([#include <math.h>], [float f = 0.0; isinf(f)],
+AC_TRY_LINK([#include <math.h>], [float f = 0.0; int r = isinf(f); return r],
AC_MSG_RESULT(yes)
AC_DEFINE(HAVE_ISINF, [1], [isinf() macro or function]),
AC_MSG_RESULT(no))