summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2005-05-05 09:15:14 +0200
committerunknown <kent@mysql.com>2005-05-05 09:15:14 +0200
commitf59fef3f972a5ae06523f811c55ef713a9303679 (patch)
tree15c771393cde23d12723e2bf34b0706c055c1e97 /configure.in
parent021171697f6ce3f53cb6b76e933d11e838d7eef7 (diff)
downloadmariadb-git-f59fef3f972a5ae06523f811c55ef713a9303679.tar.gz
terminal.c, sql_bitmap.h, my_sys.h, configure.in, config.h:
Initial Metrowerks CodeWarrior compiler support cmd-line-utils/libedit/config.h: Initial Metrowerks CodeWarrior compiler support configure.in: Initial Metrowerks CodeWarrior compiler support include/my_sys.h: Initial Metrowerks CodeWarrior compiler support sql/sql_bitmap.h: Initial Metrowerks CodeWarrior compiler support cmd-line-utils/readline/terminal.c: Initial Metrowerks CodeWarrior compiler support
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 21 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6efdc56d450..b37f0b3c537 100644
--- a/configure.in
+++ b/configure.in
@@ -127,8 +127,25 @@ AC_PROG_MAKE_SET
# This generates rules for webpage generation for the MySQL homepage.
AM_CONDITIONAL(LOCAL, test -d ../web/SitePages)
-# This is need before AC_PROG_CC
-#
+##############################################################################
+# The below section needs to be done before AC_PROG_CC
+##############################################################################
+
+# Hack for OS X/Darwin and Metrowerks CodeWarrior
+AC_ARG_WITH(darwin-mwcc,
+[ --with-darwin-mwcc Use Metrowerks CodeWarrior wrappers on OS X/Darwin],[
+ builddir=`pwd`
+ ccwrapper="$builddir/support-files/MacOSX/mwcc-wrapper"
+ arwrapper="$builddir/support-files/MacOSX/mwar-wrapper"
+ CC="$ccwrapper"
+ CXX="$ccwrapper"
+ LD="$ccwrapper"
+ AR="$arwrapper"
+ RANLIB=:
+ export CC CXX LD AR RANLIB
+ AC_SUBST(AR)
+ AC_SUBST(RANLIB)
+])
if test "x${CFLAGS-}" = x ; then
cflags_is_set=no
@@ -148,6 +165,8 @@ else
ldflags_is_set=yes
fi
+################ End of section to be done before AC_PROG_CC #################
+
# The following hack should ensure that configure doesn't add optimizing
# or debugging flags to CFLAGS or CXXFLAGS
# C_EXTRA_FLAGS are flags that are automaticly added to both