summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2004-02-19 00:00:20 +0100
committerunknown <lenz@mysql.com>2004-02-19 00:00:20 +0100
commit9c69768e3fecc41f8f0f973fe59ee9cd7e4f7d04 (patch)
treef110437bf9901a97a30af68062b99f6181681869 /configure.in
parent6c2de2409a57299d0145f47ac47565b531a06acd (diff)
downloadmariadb-git-9c69768e3fecc41f8f0f973fe59ee9cd7e4f7d04.tar.gz
- Make sure to set the correct compile flags for Mac OS X 10.3 "Panther"
(which is "darwin7" now) - "-DHAVE_BROKEN_REALPATH" is not required anymore, too, as realpath() is thread-safe on Panther now. (Thanks to Al Begley from Apple for the info)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fdb6db9f6c2..c05329a1680 100644
--- a/configure.in
+++ b/configure.in
@@ -1028,6 +1028,15 @@ case $SYSTEM_TYPE in
MAX_C_OPTIMIZE="-O"
fi
;;
+ *darwin7*)
+ if test "$ac_cv_prog_gcc" = "yes"
+ then
+ FLAGS="-DHAVE_DARWIN_THREADS -D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DFN_NO_CASE_SENCE"
+ CFLAGS="$CFLAGS $FLAGS"
+ CXXFLAGS="$CXXFLAGS $FLAGS"
+ MAX_C_OPTIMIZE="-O"
+ fi
+ ;;
*freebsd*)
echo "Adding fix for interrupted reads"
OSVERSION=`sysctl -a | grep osreldate | awk '{ print $2 }'`