summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@mysql.com>2004-02-13 16:05:09 +0200
committerunknown <monty@mysql.com>2004-02-13 16:05:09 +0200
commit0a95bda23a349639bd51c4b2c71da56ebd13d31f (patch)
tree0fed6c37f6c17ba97ac09f0dbecdf6846b11a97b /configure.in
parent82e82a88e7704330ea1ac5c7d885c1cee56c6618 (diff)
downloadmariadb-git-0a95bda23a349639bd51c4b2c71da56ebd13d31f.tar.gz
Always use libtool with "--preserve-dup-deps"
Always use all LOAD DATA options in replication. Fixed problem in mysqlbinlog where LOAD DATA options could be overwritten. client/mysqlbinlog.cc: Ensure that we don't call init_dynamic_array() before my_init() has been done configure.in: Always use libtool with "--preserve-dup-deps" to prevent link problems with g++ mysql-test/r/mysqlbinlog.result: new results mysql-test/r/range.result: new results mysql-test/t/range.test: add missing DROP TABLE sql/log_event.cc: Always use all LOAD DATA options. This is needed to handle commands of type "FIELDS TERMINATED BY ''" Allocate memory for Create_file_log_event options as these may be overwritten in mysqlbinlog sql/log_event.h: Free buffer
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5ed2105be89..ad1feefdd98 100644
--- a/configure.in
+++ b/configure.in
@@ -194,6 +194,11 @@ AC_PROG_RANLIB
#AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
+# Ensure that we have --preserve-dup-deps defines, otherwise we get link
+# problems of 'mysql' with CXX=g++
+LIBTOOL="$LIBTOOL --preserve-dup-deps"
+AC_SUBST(LIBTOOL)dnl
+
#AC_LIBTOOL_DLOPEN AC_LIBTOOL_WIN32_DLL AC_DISABLE_FAST_INSTALL AC_DISABLE_SHARED AC_DISABLE_STATIC
# AC_PROG_INSTALL