summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormonty@hundin.mysql.fi <>2001-05-31 12:19:16 +0300
committermonty@hundin.mysql.fi <>2001-05-31 12:19:16 +0300
commitbe188b117b6ebf25584201279a915c316de4c962 (patch)
treef3386d22e6d91d2fda383ebdb01fdb4614ff56ad /configure.in
parente66e6a0b86cec34ed37e2599dfae5b8a454edb80 (diff)
parent6a387c7cdf57dfe7f9a136e31ffe463d5cd28efc (diff)
downloadmariadb-git-be188b117b6ebf25584201279a915c316de4c962.tar.gz
Merge work:/home/bk/mysql into hundin.mysql.fi:/my/bk/mysql
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 38df0e950c4..37bc22ff63e 100644
--- a/configure.in
+++ b/configure.in
@@ -755,6 +755,11 @@ case $SYSTEM_TYPE in
echo "Enabling snprintf workaround for hpux 10.20"
CFLAGS="$CFLAGS -DHAVE_BROKEN_SNPRINTF -DSIGNALS_DONT_BREAK_READ"
CXXFLAGS="$CXXFLAGS -DHAVE_BROKEN_SNPRINTF -D_INCLUDE_LONGLONG -DSIGNALS_DONT_BREAK_READ"
+ if test "$with_named_thread" = "no"
+ then
+ echo "Using --with-named-thread=-lpthread"
+ with_named_thread="-lcma"
+ fi
;;
*hpux11.*)
echo "Enabling pread/pwrite workaround for hpux 11"
@@ -1051,7 +1056,7 @@ fi
AC_MSG_CHECKING("named thread libs:")
if test "$with_named_thread" != "no"
then
- LIBS="$LIBS $with_named_thread"
+ LIBS="$with_named_thread $LIBS $with_named_thread"
with_posix_threads="yes"
with_mit_threads="no"
AC_MSG_RESULT("$with_named_thread")