summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormikef@nslinux.bedford.progress.com <>2001-05-29 09:29:08 -0400
committermikef@nslinux.bedford.progress.com <>2001-05-29 09:29:08 -0400
commitceac5f9227b7ec196161feaf4e93b610946f20d9 (patch)
tree4f346bd1140daed312c2399909b0061ca3c6155d /configure.in
parentc4beb8321f8393a8b62246592b4b752eb97f09d3 (diff)
downloadmariadb-git-ceac5f9227b7ec196161feaf4e93b610946f20d9.tar.gz
Pushing all the Gemini changes above the table handler.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9998902bcec..47df228d310 100644
--- a/configure.in
+++ b/configure.in
@@ -2018,6 +2018,17 @@ EOF
echo "END OF INNODB CONFIGURATION"
fi
+ if test "X$have_gemini_db" = "Xyes"; then
+ sql_server_dirs="gemini $sql_server_dirs"
+ echo "CONFIGURING FOR GEMINI DB"
+ (cd gemini && sh ./configure) \
+ || AC_MSG_ERROR([could not configure Gemini DB])
+
+ echo "END OF GEMINI DB CONFIGURATION"
+
+ AC_DEFINE(HAVE_GEMINI_DB)
+ fi
+
if test "$with_posix_threads" = "no" -o "$with_mit_threads" = "yes"
then
# MIT user level threads