summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2006-02-28 23:29:58 +0100
committerunknown <kent@mysql.com>2006-02-28 23:29:58 +0100
commit3addd306a66b146ae5500f1bce5e6ddba036c8e8 (patch)
treeefd2f0f295954c586163d618728c858a8dde7543 /configure.in
parent59b6ab1fe01f48fb4def09f9565b842aa78e5f8e (diff)
parentfb936d2a86416127c031f3972f669e1c2b4291b3 (diff)
downloadmariadb-git-3addd306a66b146ae5500f1bce5e6ddba036c8e8.tar.gz
Merge
configure.in: Auto merged client/mysqlimport.c: Auto merged include/config-win.h: Auto merged mysql-test/r/create.result: Auto merged mysql-test/t/create.test: Auto merged mysql-test/t/disabled.def: Auto merged scripts/mysql_fix_privilege_tables.sql: Auto merged sql/field.h: Auto merged sql/log_event.h: Auto merged sql/sql_parse.cc: Auto merged sql/sql_partition.cc: Auto merged sql/sql_table.cc: Auto merged mysql-test/t/mysqldump.test: SCCS merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 6519f997d24..f7017e4455c 100644
--- a/configure.in
+++ b/configure.in
@@ -592,10 +592,10 @@ AC_ARG_WITH(named-curses-libs,
# Make thread safe client
AC_ARG_ENABLE(thread-safe-client,
- [ --enable-thread-safe-client
- Compile the client with threads.],
+ [ --disable-thread-safe-client
+ Compile the client without threads.],
[ THREAD_SAFE_CLIENT=$enableval ],
- [ THREAD_SAFE_CLIENT=no ]
+ [ THREAD_SAFE_CLIENT=yes ]
)
# compile with strings functions in assembler
@@ -1567,7 +1567,8 @@ then
fi
AC_ARG_WITH(debug,
- [ --without-debug Build a production version without debugging code],
+ [ --with-debug Add debug code
+ --with-debug=full Add debug code (adds memory checker, very slow)],
[with_debug=$withval],
[with_debug=no])
if test "$with_debug" = "yes"
@@ -2475,6 +2476,8 @@ dnl client is just using plain-old libs.
sql_client_dirs="strings regex mysys libmysql client"
linked_client_targets="linked_libmysql_sources"
+AM_CONDITIONAL(THREAD_SAFE_CLIENT, test "$THREAD_SAFE_CLIENT" != "no")
+
if test "$THREAD_SAFE_CLIENT" != "no"
then
sql_client_dirs="libmysql_r $sql_client_dirs"