summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChad MILLER <chad@mysql.com>2009-05-05 17:03:23 -0400
committerChad MILLER <chad@mysql.com>2009-05-05 17:03:23 -0400
commit4822696ecb7302efc543e0be109f1c2a8f1bdf4e (patch)
tree14698de1876a7bea69d52b7f7ddaedbf0877551f /configure.in
parent14f923c0286588f9f391a2fda8b9fab5a4e2953c (diff)
downloadmariadb-git-4822696ecb7302efc543e0be109f1c2a8f1bdf4e.tar.gz
Pull 5.1 treatment of community features into 5.0.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 30 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index afadd2e0c40..866f12c47a2 100644
--- a/configure.in
+++ b/configure.in
@@ -661,7 +661,6 @@ then
fi
fi
-
AC_ARG_WITH(server-suffix,
[ --with-server-suffix Append value to the version string.],
[ MYSQL_SERVER_SUFFIX=`echo "$withval" | sed -e 's/^\(...................................\)..*$/\1/'` ],
@@ -724,17 +723,42 @@ else
AC_MSG_RESULT([no])
fi
+AC_MSG_CHECKING(whether features provided by the user community should be included.)
+AC_ARG_ENABLE(community-features,
+ AC_HELP_STRING(
+ [--enable-community-features],
+ [Enable additional features provided by the user community.]),
+ [ ENABLE_COMMUNITY_FEATURES=$enableval ],
+ [ ENABLE_COMMUNITY_FEATURES=no ]
+ )
+
+if test "$ENABLE_COMMUNITY_FEATURES" = "yes"
+then
+ AC_DEFINE([COMMUNITY_SERVER], [1],
+ [Whether features provided by the user community should be included])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
# Add query profiler
+AC_MSG_CHECKING(whether query profiling should be included)
AC_ARG_ENABLE(profiling,
- AS_HELP_STRING([--disable-profiling], [Build a version without query profiling code]),
+ AS_HELP_STRING([--enable-profiling], [Add query-profiling code.]),
[ ENABLED_PROFILING=$enableval ],
- [ ENABLED_PROFILING=yes ])
+ [ ENABLED_PROFILING=no ])
if test "$ENABLED_PROFILING" = "yes"
then
- AC_DEFINE([ENABLED_PROFILING], [1],
- [If SHOW PROFILE should be enabled])
- AC_MSG_RESULT([yes])
+ if test "$ENABLE_COMMUNITY_FEATURES" = "yes";
+ then
+ AC_DEFINE([ENABLED_PROFILING], [1], [If SHOW PROFILE should be enabled])
+ AC_MSG_RESULT([yes])
+ else
+ ENABLED_PROFILING="no"
+ AC_MSG_RESULT([no, overridden because community-features disabled])
+ AC_MSG_ERROR([This is almost certainly wrong. Add --enable-community-features or remove --enable-profiling .])
+ fi
else
AC_MSG_RESULT([no])
fi