summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-01-01 07:22:57 +0100
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-01-01 07:22:57 +0100
commit190a79c7f0e3f656bca932c213b3c48d5f4c8fd4 (patch)
tree655de5b1654d11ff436118b5bc44477ce9d744df /configure.in
parentefe0db3f70f7b1372c65181c91c7144a093f3a4a (diff)
downloadmariadb-git-190a79c7f0e3f656bca932c213b3c48d5f4c8fd4.tar.gz
configure.in:
Don't build server when configured --without-server (bug#23973) configure.in: Don't build server when configured --without-server (bug#23973)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4ac0637e42c..8457a2dcad0 100644
--- a/configure.in
+++ b/configure.in
@@ -2990,10 +2990,14 @@ AM_CONDITIONAL(HAVE_NETWARE, test "$netware_dir" = "netware")
export CC CXX CFLAGS CXXFLAGS LD LDFLAGS AR
ac_configure_args="$ac_configure_args CFLAGS='$CFLAGS' CXXFLAGS='$CXXFLAGS'"
-if test "$with_server" = "yes" -o "$THREAD_SAFE_CLIENT" != "no"
+if test "$with_server" != "no" -o "$THREAD_SAFE_CLIENT" != "no"
then
AC_DEFINE([THREAD], [1],
[Define if you want to have threaded code. This may be undef on client code])
+fi
+
+if test "$with_server" != "no"
+then
# Avoid _PROGRAMS names
THREAD_LPROGRAMS="test_thr_alarm\$(EXEEXT) test_thr_lock\$(EXEEXT)"
AC_SUBST(THREAD_LPROGRAMS)