summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormats@mysql.com <>2006-02-28 10:06:58 +0100
committermats@mysql.com <>2006-02-28 10:06:58 +0100
commit1e66bc0d160a2265e00c76ff369caa9b97e2a9bb (patch)
treecb6ade436bf4b0cf01026964400f9aa8fb2f4ff9 /configure.in
parentf0f8795bebc90843e837cda4249d2872a21b3960 (diff)
parent13a61982a99ece6b5c01e5c3d29e6e93e4bb20f9 (diff)
downloadmariadb-git-1e66bc0d160a2265e00c76ff369caa9b97e2a9bb.tar.gz
Merge mysql.com:/home/bkroot/mysql-5.1-new
into mysql.com:/home/bk/w3023-mysql-5.1-new
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 6519f997d24..f7017e4455c 100644
--- a/configure.in
+++ b/configure.in
@@ -592,10 +592,10 @@ AC_ARG_WITH(named-curses-libs,
# Make thread safe client
AC_ARG_ENABLE(thread-safe-client,
- [ --enable-thread-safe-client
- Compile the client with threads.],
+ [ --disable-thread-safe-client
+ Compile the client without threads.],
[ THREAD_SAFE_CLIENT=$enableval ],
- [ THREAD_SAFE_CLIENT=no ]
+ [ THREAD_SAFE_CLIENT=yes ]
)
# compile with strings functions in assembler
@@ -1567,7 +1567,8 @@ then
fi
AC_ARG_WITH(debug,
- [ --without-debug Build a production version without debugging code],
+ [ --with-debug Add debug code
+ --with-debug=full Add debug code (adds memory checker, very slow)],
[with_debug=$withval],
[with_debug=no])
if test "$with_debug" = "yes"
@@ -2475,6 +2476,8 @@ dnl client is just using plain-old libs.
sql_client_dirs="strings regex mysys libmysql client"
linked_client_targets="linked_libmysql_sources"
+AM_CONDITIONAL(THREAD_SAFE_CLIENT, test "$THREAD_SAFE_CLIENT" != "no")
+
if test "$THREAD_SAFE_CLIENT" != "no"
then
sql_client_dirs="libmysql_r $sql_client_dirs"