summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tsmith@siva.hindu.god>2007-01-09 19:22:01 -0700
committerunknown <tsmith@siva.hindu.god>2007-01-09 19:22:01 -0700
commitc2e9a4af2dcebee419398a17530ef5c28d7962a9 (patch)
tree66654967ac4cd7bca3c3211426681a8f9ce3879d /configure.in
parenta1ecbab689ed475ce61c05c7b02609b1efe5e660 (diff)
downloadmariadb-git-c2e9a4af2dcebee419398a17530ef5c28d7962a9.tar.gz
WL #3670: Compile-time option to remove GRANT-related startup options
- configure --disable-grant-options defines DISABLE_GRANT_OPTIONS - configure.js/cmake also updated - if DISABLE_GRANT_OPTIONS is defined, mysqld no longer recognizes: --bootstrap --init-file --skip-grant-tables Scripts which rely on those three options are modified to check the environment for MYSQLD_BOOTSTRAP; it should be set to the full path of a mysqld which does handle those options. For example: $ export MYSQLD_BOOTSTRAP $ MYSQLD_BOOTSTRAP=/path/to/full/MySQL/bin/mysqld $ mysql_install_db $ make test configure.in: WL#3670 Add --disable-grant-options mysql-test/install_test_db.sh: Add MYSQLD_BOOTSTRAP env variable, to enable test suite to work even if mysqld does not accept --bootstrap or --skip-grant-tables. mysql-test/mysql-test-run.pl: Add MYSQLD_BOOTSTRAP env variable, to enable test suite to work even if mysqld does not accept --bootstrap or --skip-grant-tables. mysql-test/mysql_test_run_new.c: Mention need for MYSQLD_BOOTSTRAP in a comment, in case this needs to be used with a mysqld which does not accept the --bootstrap option. scripts/mysql_install_db.sh: Add MYSQLD_BOOTSTRAP env variable, to enable mysqld_install_db to work even if mysqld does not accept --bootstrap or --skip-grant-tables. sql/CMakeLists.txt: Add DISABLE_GRANT_OPTIONS define sql/mysqld.cc: Add DISABLE_GRANT_OPTIONS define, which removes the --bootstrap, --init-file, and --skip-grant-tables options win/README: Document the DISABLE_GRANT_OPTIONS define win/configure.js: Handle DISABLE_GRANT_OPTIONS
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f6a6eedac70..19fe70c0c4d 100644
--- a/configure.in
+++ b/configure.in
@@ -713,6 +713,22 @@ else
AC_MSG_RESULT([no])
fi
+# If we should allow init-file and skip-grant-table options
+AC_MSG_CHECKING(If we should should enable init-file and skip-grant-table options)
+AC_ARG_ENABLE(grant-options,
+ [ --disable-grant-options Disables the use of --init-file and --skip-grant-tables options],
+ [ mysql_grant_options_enabled=$enableval ],
+ [ mysql_grant_options_enabled=no ]
+ )
+if test "$mysql_grant_options_enabled" = "yes"
+then
+ AC_MSG_RESULT([yes])
+else
+ AC_DEFINE([DISABLE_GRANT_OPTIONS], [1],
+ [Disables the use of --init-file and --skip-grant-tables options])
+ AC_MSG_RESULT([no])
+fi
+
MYSQL_SYS_LARGEFILE
# Types that must be checked AFTER large file support is checked