summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMats Kindahl <mats@sun.com>2008-10-06 10:27:36 +0200
committerMats Kindahl <mats@sun.com>2008-10-06 10:27:36 +0200
commitbcaf5e0cf55fe87bf77fde836a8913ec170d7085 (patch)
tree7bac6ffa1fec91510d6ec0791124a707d0f29e3a /configure.in
parent08399602a61dc9561773e178b8eabfb99b1ce945 (diff)
parent9daa56fd5ce3ccd33c32b5a505ac1d2b2c437460 (diff)
downloadmariadb-git-bcaf5e0cf55fe87bf77fde836a8913ec170d7085.tar.gz
Merging 5.1 main into 5.1-rpl.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 9 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index 2b3eb883b8c..4483910526b 100644
--- a/configure.in
+++ b/configure.in
@@ -419,6 +419,7 @@ AC_PATH_PROG(SED, sed, sed)
AC_PATH_PROG(CMP, cmp, cmp)
AC_PATH_PROG(CHMOD, chmod, chmod)
AC_PATH_PROG(HOSTNAME, hostname, hostname)
+AC_PATH_PROG(DIFF, diff, diff)
# Check for a GNU tar named 'gtar', or 'gnutar' (MacOS X) and
# fall back to 'tar' otherwise and hope that it's a GNU tar as well
AC_CHECK_PROGS(TAR, gnutar gtar tar)
@@ -443,25 +444,16 @@ AC_SUBST(HOSTNAME)
AC_SUBST(PERL)
AC_SUBST(PERL5)
-# icheck, used for ABI check
-AC_PATH_PROG(ICHECK, icheck, no)
-# "icheck" is also the name of a file system check program on Tru64.
-# Verify the program found is really the interface checker.
-if test "x$ICHECK" != "xno"
+# Enable the abi_check rule only if gcc is available
+
+if expr "$CC" : ".*gcc.*"
then
- AC_MSG_CHECKING(if $ICHECK works as expected)
- echo "int foo;" > conftest.h
- $ICHECK --canonify -o conftest.ic conftest.h 2>/dev/null
- if test -f "conftest.ic"
- then
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
- ICHECK=no
- fi
- rm -f conftest.ic conftest.h
+ ABI_CHECK="abi_check"
+else
+ ABI_CHECK=""
fi
-AC_SUBST(ICHECK)
+
+AC_SUBST(ABI_CHECK)
# Lock for PS
AC_PATH_PROG(PS, ps, ps)