summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormonty@hundin.mysql.fi <>2002-03-26 11:40:18 +0200
committermonty@hundin.mysql.fi <>2002-03-26 11:40:18 +0200
commitbeedaf26ecf6fa78b1b74b805e8ad24cbd315733 (patch)
tree3cd48b2d030654d3ff91a6d43aa0dec422f1ca05 /configure.in
parent37522497ac0385ccab7ef3fbe21f86811f49c59f (diff)
downloadmariadb-git-beedaf26ecf6fa78b1b74b805e8ad24cbd315733.tar.gz
Move test of gcc 3.0 from BUILD to configure
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 959073eda02..b55f1f6f726 100644
--- a/configure.in
+++ b/configure.in
@@ -321,6 +321,19 @@ then
# Disable exceptions as they seams to create problems with gcc and threads.
# mysqld doesn't use run-time-type-checking, so we disable it.
CXXFLAGS="$CXXFLAGS -fno-implicit-templates -fno-exceptions -fno-rtti"
+
+ # If you are using 'gcc' 3.0 (not g++) to compile C++ programs,
+ # we will gets some problems when linking static programs.
+ # The following code is used to fix this problem.
+
+ if test "$CXX" = "gcc"
+ then
+ if $CXX -v 2>&1 | grep 'version 3' > /dev/null 2>&1
+ then
+ CXXFLAGS="$CXXFLAGS -DUSE_MYSYS_NEW"
+ CXXLDFLAGS="$CXXLDFLAGS -Wl,--defsym -Wl,__cxa_pure_virtual=0"
+ fi
+ fi
fi
# Avoid bug in fcntl on some versions of linux