summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@hundin.mysql.fi>2002-03-25 18:10:34 +0200
committerunknown <monty@hundin.mysql.fi>2002-03-25 18:10:34 +0200
commit9ee0658adc1d79528e8a1b78c0369ebad6bb57d0 (patch)
tree37e6dbff799fdd1e484007e0c2cec9bf3bbb073a /configure.in
parent9ed83bda3d196552934eaa8fa284463e87f82865 (diff)
downloadmariadb-git-9ee0658adc1d79528e8a1b78c0369ebad6bb57d0.tar.gz
Fixed that RPM can be recompiled even if there is not another glibc in /usr/local/mysql-glibc
Build-tools/Do-compile: Fix to build mysqlcom Build-tools/Do-rpm: Fixes for building with gcc 3.0.4 Docs/manual.texi: Small bug fix configure.in: Cleanup
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 14 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index c6cda3c157f..48c12d3b471 100644
--- a/configure.in
+++ b/configure.in
@@ -436,16 +436,17 @@ AC_ARG_WITH(other-libc,
enable_shared="no"
all_is_static="yes"
CFLAGS="$CFLAGS -I$other_libc_include"
+ # There seems to be a feature in gcc that treats system and libc headers
+ # silently when they violatate ANSI C++ standard, but it is strict otherwise
+ # since gcc cannot now recognize that our headers are libc, we work around
+ # by telling it to be permissive. Note that this option only works with
+ # new versions of gcc (2.95.x and above)
CXXFLAGS="$CXXFLAGS -fpermissive -I$other_libc_include"
-#There seems to be a feature in gcc that treats system and libc headers
-#leniently when they violatate ANSI C++ standard, but it is strict otherwise
-#since gcc cannot now recognize that our headers are libc, we work around
-#by telling it to be permissive
static_nss=
if test -f "$other_libc_lib/libnss_files.a"
then
- # libc has been compiled with --enable-static-nss
- # we need special flags, but we will have to add those later
+ # libc has been compiled with --enable-static-nss
+ # we need special flags, but we will have to add those later
STATIC_NSS_FLAGS="-Wl,--start-group -lc -lnss_files -lnss_dns -lresolv \
-Wl,--end-group"
static_nss=1
@@ -461,12 +462,12 @@ AC_ARG_WITH(other-libc,
LDFLAGS="$LDFLAGS -static -L$other_libc_lib "
fi
+ # When linking against custom libc installed separately, we want to force
+ # all binary builds to be static, including the build done by configure
+ # itself to test for system features.
with_mysqld_ldflags="-all-static"
with_client_ldflags="-all-static"
NOINST_LDFLAGS="-all-static"
-#when linking against custom libc installed separately, we want to force all
-#binary builds to be static, including the build done by configure itself
-#to test for system features
],
[
other_libc_include=
@@ -1512,9 +1513,9 @@ ac_save_CXXFLAGS="$CXXFLAGS"
AC_CACHE_CHECK([style of gethost* routines], mysql_cv_gethost_style,
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
-#do not treat warnings as errors if we are linking agaist other libc
-#this is to work around gcc not being permissive on non-system includes
-#with respect to ANSI C++
+# Do not treat warnings as errors if we are linking agaist other libc
+# this is to work around gcc not being permissive on non-system includes
+# with respect to ANSI C++
if test "$ac_cv_prog_gxx" = "yes" -a "$with_other_libc" = "no"
then
CXXFLAGS="$CXXFLAGS -Werror"
@@ -2204,7 +2205,7 @@ then
fi
fi
-#IMPORTANT - do not modify LIBS past this line - this hack is the only way
+# IMPORTANT - do not modify LIBS past this line - this hack is the only way
# I know to add the static NSS magic if we have static NSS libraries with
# glibc - Sasha